PAT乙级练习题1019 数字黑洞

题目:

给定任一个各位数字不完全相同的4位正整数,如果我们先把4个数字按非递增排序,再按非递减排序,然后用第1个数字减第2个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的6174,这个神奇的数字也叫Kaprekar常数。
例如,我们从6767开始,将得到
7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174
7641 – 1467 = 6174
… …
现给定任意4位正整数,请编写程序演示到达黑洞的过程。

输入格式:

输入给出一个(0, 104)区间内的正整数N。

输出格式:

如果N的4位数字全相等,则在一行内输出“N – N = 0000”;否则将计算的每一步在一行内输出,直到6174作为差出现,输出格式见样例。注意每个数字按4位数格式输出。

输入样例1:

6767

输出样例1:

7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174

输入样例2:

2222

输出样例2:

2222 – 2222 = 0000

思路:

用字符串接收数据,排序后转换为数字做运算,再转换回字符串输出

踩坑:

  • 题目说了会输入4位不相同的正整数,但是实际上可能会输入小于四位的数字,此时要在前面补0(否则2,3,4测试点运行超时或答案错误,一直怀疑运行超时是不是用了很多atoi和to_string之类的函数,但事实是处理不当导致循环无法结束)
  • 在进行数字运算的过程中也可能出现不足四位的数字,最后输出时要在前面补0
  • 会有输入数字为6174的情况,对此数字也要进行处理

代码:

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;

int cmp(char a, char b){
    return a > b;
}

int main(){
    string input;
    
    cin >> input;
    string temp = input;
    temp.insert(0, 4 - temp.length(), '0');
    string temp1;
    string temp2;

	//处理相同数字的情况
    int flag = 1;
    for(int i = 0; i < 3; ++i){
        if(temp[i] == temp[i+1]){
            flag = 1;
        }
        else{
            flag = 0;
            break;
        }
    }
    
    if(flag){
        printf("%s - %s = 0000\n", temp.c_str(), temp.c_str());
    }
    else{
    	//先执行一次,处理第一个数字是6174的情况
        do{
            sort(temp.begin(), temp.end(), cmp);
            temp1 = temp;
            sort(temp.begin(), temp.end());
            temp2 = temp;
            temp =  to_string(stoi(temp1) - stoi(temp2));
            temp.insert(0, 4 - temp.length(), '0');
            printf("%s - %s = %s\n", temp1.c_str(), temp2.c_str(), temp.c_str());
        }
        while(temp != "6174");
    }
    
    return 0;
}

优化:

字符串中的数字全部相同的话,想减自然为0,而在前面会补0到4位,可以跟普通情况一起输出,就不用额外判断是不是相同数字了。

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;

int cmp(char a, char b){
    return a > b;
}

int main(){
    string input;
    
    cin >> input;
    
    string temp = input;
    temp.insert(0, 4 - temp.length(), '0');
    string temp1;
    string temp2;
    
    do{
        sort(temp.begin(), temp.end(), cmp);
        temp1 = temp;
        sort(temp.begin(), temp.end());
        temp2 = temp;
        temp =  to_string(stoi(temp1) - stoi(temp2));
        temp.insert(0, 4 - temp.length(), '0');
        printf("%s - %s = %s\n", temp1.c_str(), temp2.c_str(), temp.c_str());
    }
    while(temp != "6174" && temp != "0000");
    
    return 0;
}

学到和回忆了:

  • 用insert函数对数字字符串补0

参考的解析:

1019. 数字黑洞 (20)-PAT乙级真题

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值