HDU-5723 Abandoned country

Problem Description
An abandoned country has  n(n100000)  villages which are numbered from 1 to  n . Since abandoned for a long time, the roads need to be re-built. There are  m(m1000000)  roads to be re-built, the length of each road is  wi(wi1000000) . Guaranteed that any two  wi  are different. The roads made all the villages connected directly or indirectly before destroyed. Every road will cost the same value of its length to rebuild. The king wants to use the minimum cost to make all the villages connected with each other directly or indirectly. After the roads are re-built, the king asks a men as messenger. The king will select any two different points as starting point or the destination with the same probability. Now the king asks you to tell him the minimum cost and the minimum expectations length the messenger will walk.
 

Input
The first line contains an integer  T(T10)  which indicates the number of test cases. 

For each test case, the first line contains two integers  n,m  indicate the number of villages and the number of roads to be re-built. Next  m  lines, each line have three number  i,j,wi , the length of a road connecting the village  i  and the village  j  is  wi .
 

Output
output the minimum cost and minimum Expectations with two decimal places. They separated by a space.
 

Sample Input
  
  
1 4 6 1 2 1 2 3 2 3 4 3 4 1 4 1 3 5 2 4 6
 

Sample Output
  
  
6 3.33
 

Author
HIT
 

Source

题目大意:

有n个点,有m条边,让你求它的最小生成树,并且在这个生成树上,求任意两点间的距离的期望。

解题思路:

第一问比较裸,就直接求最小生成树就好,第二问需要一些技巧。

现在有一条边ab,其中b的子树个数为num,那么这条边被经过的次数为(n - num) * num

然后乘一下这条边的权值就可以了

代码:

#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 1e5 + 5;

typedef long long LL;
typedef struct node{
    int from, to;
    int w;
    bool operator < (node zz){
        return w < zz.w;
    }
}Edge;
typedef struct nn{
    int to;
    int w;
    nn(){}
    nn(LL a, LL b){
        to = a; w = b;
    }
}EEE;

LL ans;
double res;
int t, n, m;
Edge g[maxn * 10];
vector<EEE> e[maxn];
int vis[maxn], pre[maxn];

int findfather(int x){
    return pre[x] = (pre[x] == x ? x : findfather(pre[x]));
}
void join(int x, int y){
    pre[findfather(x)] = findfather(y);
}
void kruskal(){
    int x, y, flag = 0;
    for(int i = 0; i < m; ++i){
        x = findfather(g[i].from);
        y = findfather(g[i].to);

        if(x == y) continue;
        join(x, y);
        ++flag;
        ans += g[i].w;
        e[g[i].from].push_back(nn(g[i].to, g[i].w));
        e[g[i].to].push_back(nn(g[i].from, g[i].w));

        if(flag == n - 1) return;
    }
}
int dfs(int p){
    if(vis[p]) return 0;
    vis[p] = 1;

    int tt = 1, num;
    for(int i = 0; i < e[p].size(); ++i){
        int v = e[p][i].to;
        num = dfs(v);
        tt += num;
        res += (LL)(n - num) * (LL)num * (LL)e[p][i].w;
    }
    return tt;
}
int main(){
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n; ++i) {
            pre[i] = i;
            vis[i] = 0;
            e[i].clear();
        }
        for(int i = 0; i < m; ++i){
            scanf("%d%d%d", &g[i].from, &g[i].to, &g[i].w);
        }
        sort(g, g + m);
        ans = 0;
        kruskal();

        res = 0;
        dfs(1);
        printf("%lld %.2lf\n", ans, res / ((n - 1LL) * n / 2.0));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值