POJ-1861 Network

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

题目大意:

给你n个点,给你m条边,找出它的最小生成树,最后输出这个生成树长度最长的边的长度,这个生成树有多少边,这个生成树所有的边

解题思路:

裸最小生成树。kruskal+并查集

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 1000 + 5;
const int maxs = 15000 + 5;

typedef struct node{
    int from, to;
    int val;
    node(int x = 0, int y = 0, int w = 0){
        from = x; to = y; val = w;        
    }
    bool operator < (const node p){
        return val < p.val;
    }
}PATH;

int n, m, pre[maxn];
PATH ans[maxn], r[maxs];

int findfather(int x){
    return pre[x] = (pre[x] == x ? x : findfather(pre[x]));
}
void kruskal(){
    memset(ans, 0, sizeof(ans));
    int tol = 0, res = 0;
    for(int i = 0; i < m; ++i){
        int fx = findfather(r[i].from);
        int fy = findfather(r[i].to);
        if(fx == fy) continue;
        pre[fx] = fy;
        ans[tol++] = r[i];
        res = max(res, r[i].val);
        
        if(tol == n) break;
    }
    
    printf("%d\n%d\n", res, tol);
    for(int i = 0; i < tol; ++i){
        printf("%d %d\n", ans[i].from, ans[i].to);
    }
}
int main(){
    // freopen("test.in", "r+", stdin);
    // freopen("test.out", "w+", stdout);
    while(~scanf("%d%d", &n, &m)){
        memset(r, 0, sizeof(r));
        for(int i = 0; i <= n; ++i) pre[i] = i;
        for(int i = 0; i < m; ++i) scanf("%d%d%d", &r[i].from, &r[i].to, &r[i].val);
        sort(r, r + m);
        kruskal();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值