hdu---1591Encoded Love-letter

Encoded Love-letter

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1231    Accepted Submission(s): 439


Problem Description
After Gardon had got Angel's letter, he found it was encoded...Oh my god, why did she encode a love-letter?? But don't worry, she wrote the algorithm for encoding after the letter:
Each charactor are changed to a corresponding charactor. If the keyword is "Angel", the rule will be:

ABCDEFGHIJKLMNOPQRSTUVWXYZ
ANGELZYXWVUTSRQPOMKJIHFDCB

You may find that in the bottom line, charactors of the keyword come first. All other charactors will come in a reversed order.

Now given another keyword, work the letter out!
Can you write a program to translate the letter?
 

 

Input
The letter will begin with the keyword (All uppercase), then lines of text.
 

 

Output
Decode the letter and print it out. Please note that a upper-case charactor will be decoded to a upper-case charactor, while a lower-case charactor will be decoded to a lower-case charactor.
 

 

Sample Input
ANGEL Fxlr jxaj eac W xlam cqim hqwgl W xahl kqsl kplgwat zlltwry Tlj sl atfack jxwru W eqr'j farra zqmylj cqi W mlslsnlm aj jxl eac Cqi aml atfack qr sc swre Lhlrjxqiyx W vikj gar jxwru anqij cqi Wz jxl eac wr jxl zijiml Jxwk tqhl fwtt nlgqswry jmil W'hl rlhlm gxaryl sc swre jxaj W fwtt tqhl cqi zqmlhlm W eqr'j gaml xqf zqqt wj wk W fwtt tlj sc emlas gqsl jmil W fwtt jltt cqi kqsljxwry W farra tlj cqi urqf, W tlj cqi urqf W tqhl cqi, tqhwry cqi, ak jxl sqikl tqhlk jxl mwgl Lhlr lhlmc eac xak kjqms, W fwtt atfack nc cqim kwel W swkk cqi, swkkwry cqi W eqr'j gaml xqf xame wj wk W vikj farj cqi jq nl xappc Lhlmcjxwry, W eq wj zqm cqi
 

 

Sample Output
When that day I hear your voice I have some special feeling Let me always think I don't wanna forget you I remember at the day You are always on my mind Eventhough I just can think about you If the day in the future This love will becoming true I've never change my mind that I will love you forever I don't care how fool it is I will let my dream come true I will tell you something I wanna let you know, I let you know I love you, loving you, as the mouse loves the rice Even every day has storm, I will always by your side I miss you, missing you I don't care how hard it is I just want you to be happy Everything, I do it for you
 
 
 
 
//水题一枚,贴这个题主要是学习一下字符串的读入方式;  以及当段落之间输入有空行时,怎么处理。
// 这里是用的  判断 strlen(str) 是否为 0  来进行的判断。
// 读入含有空格的字符串这里使用的是 gets(str); 
代码:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#define N 30
char f[N]={"1ABCDEFGHIJKLMNOPQRSTUVWXYZ "},f1[N];
char str[N];
int ff[N];
char s[1000];
int main()
{
    int i,j,k=0;
    freopen("in.txt","r",stdin);
    scanf("%s",str);getchar();
        //for(i=0;i<N;i++) ff[i]=0;
        int len=strlen(str);
        for(i=1;i<=len;i++){
            f1[i]=str[i-1];
            ff[str[i-1]-'A'+1]=1;
        }
        j=i;
        for(i=26;i>=1;i--)
            if(ff[i]==0)
                f1[j++]='A'-1+i;
        char x=' ';
        //得到转换的字符数组。
    while(gets(s)){
        len=strlen(s);
        if(len==0) printf("\n");
        else{
            for(i=0;i<len;i++){
                for(j=1;j<=26;j++)
                    if(s[i]==f1[j] || s[i]==f1[j]-'A'+'a')
                        break;
                if(j==27)
                    printf("%c",s[i]);
                else if(s[i]>='a' && s[i]<='z')
                    printf("%c",f[j]-'A'+'a');
                else printf("%c",f[j]);
            }
            printf("\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值