1103. Integer Factorization (30)

时间限制

1200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112+ 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

C++:

/*
 @Date    : 2018-02-22 19:04:55
 @Author  : 酸饺子 (changzheng300@foxmail.com)
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://www.patest.cn/contests/pat-a-practise/1103
 */

#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
#include <algorithm>

using namespace std;

static const int MAXN = 401;
static vector<int> powerData(401);
static vector<int> thisFactors, resFactors;
static int thisFactorSum = 0, maxFactorSum = 0;
static int lastFactor; // 后一个因子不能大于前一个因子

void DFS(int N, int K, int P)
{
    if (K == 0)
    {
        if (N == 0)
        {
            if (thisFactorSum > maxFactorSum)
            {
                maxFactorSum = thisFactorSum;
                resFactors = thisFactors;
            }
            else if (thisFactorSum == maxFactorSum && thisFactors > resFactors)
                resFactors = thisFactors;
        }
    }
    else if (N != 0)
    {
        int tempLastFactor = lastFactor;
        for (int i = 1; i <= lastFactor; ++i)
        {
            if (powerData[i] > N) break;
            thisFactorSum += i;
            thisFactors.push_back(i);
            lastFactor = i;
            DFS(N - powerData[i], K - 1, P);
            lastFactor = tempLastFactor;
            thisFactorSum -= i;
            thisFactors.pop_back();
        }
    }
    return;
}

int my_power(int x, int e)
{
    int res = x;
    for (int i = 2; i != e + 1; ++i)
        res *= x;
    return res;
}

int main(int argc, char const *argv[])
{
    int N, K, P;
    scanf("%d %d %d", &N, &K, &P);
    for (int i = 1; i <= N; ++i)
        powerData[i] = my_power(i, P);
    lastFactor = N;
    DFS(N, K, P);
    if (!resFactors.empty())
    {
        int output = 0;
        printf("%d =", N);
        for (int f : resFactors)
        {
            if (output++) printf(" +");
            printf(" %d^%d", f, P);
        }
        putchar('\n');
    }
    else
        printf("Impossible\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值