POJ1068,Parencodings,模拟题,但用的是数学规律

Parencodings

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

S (((()()())))

P-sequence    4 5 6666

W-sequence    1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 


Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.


Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.


Sample Input

2
6
4 5 6 6 6 6

4 6 6 6 6 8 9 9 9


Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


分析:

题意是一串左右括号组成的串,有两种方式表示。

p方式,第i个右括号左边有p[i]个左括号,给出序列p。要你求出按w方式,即从左到有第i个右括号往左第w[i]个左括号与之配对。E文好多了有木有。。。

第一反应当然是根据p序列求出原串再算出w序列,算法清晰,代码量大。直觉上这题可以直接找出p到w的规律而跳过s。w[i]可以根据p[i],p[i-1]...来推出,临界条件就是p[i]-p[j]<i-j。。。用心体会= =


code:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include<string>
using namespace std;
int p[20+1];
int main()
{
    int t,n,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&p[i]);
            j=i-1;
            if(j<0) printf("%d ",1);
            else
            {
                while(p[i]-p[j]<i-j) j--;
                printf("%d ",i-j);
            }
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值