Shortest Distance 问题

                                          问题 E: Shortest Distance (20)

                                                                        时间限制: 1 Sec  内存限制: 32 MB

http://codeup.cn/problem.php?cid=100000575&pid=4

问题描述

         给出N个点的距离,求最短距离。

输入

第一行输入一个n(3<=n<=10^5),之后n个数D1,D2,...Dn表示距离,Di表示i到i+1的距离(1<=i<=n-1),Dn表示n到1之间的距离。第二行输入一个m(m<=10^4),之后m行每行输入2个点(a,b)即起点和终点。

输出

对每一个名输出(a,b)输出从a到b的最短距离。

样例输入

5  1  2  4  14  9

3

1  3

2  5

4  1

样例输出

3

10

7

#include<stdio.h>
int main(){
	int a[100000],b[10000];
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d",&a[i]);
	}
	int m;
	scanf("%d",&m);
	for(int i=1;i<=m;i++){
		int p,q;
		scanf("%d %d",&p,&q);
		int x=0,y=0;
		if(p<q){
			for(int j=p;j<q;j++){
				x+=a[j];
			}
			while(p--){
				if(p==0){
					p=n;
				}
				y+=a[p];
				if(p==q){
					break;
				}
			}
		}else{
			for(int j=q;j<p;j++){
				x+=a[j];
			}
			while(p--){
				if(p==0){
					p=n;
				}
				y+=a[p];
				if(p==q){
					break;
				}
			}
		}
		if(x<y){
			b[i]=x;
		}else{
			b[i]=y;
		}
	}	 
	for(int i=1;i<=m;i++){
		printf("%d\n",b[i]);
	}
	return 0;
}

此算法结果正确但时间超限,跪求正确解法。

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks. Input Line 1: Three space-separated integers: L, N, and M Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position. Output Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks Sample Inputcopy Outputcopy 25 5 2 2 14 11 21 17 4 Hint Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
最新发布
07-24
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值