POJ - 1988 Cube Stacking

28 篇文章 0 订阅

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

题目大意:有几个stack,初始里面有一个cube。支持两种操作:1.move x y: 将x所在的stack移动到y所在stack的顶部。2.count x:数在x所在stack中,在x之下的cube的个数。


是一个并查集的题目,但是有权值的并查集不是很简单,废了很多脑子,看了很多题解。

记录下每个子集的大小和到底部的距离,每次合并的时候就更新。


#include <iostream>
#include <cstdio>
using namespace std;

int counts[30005];
int dis[30005];
int pre[30005];

int findfather(int x)
{
    if (pre[x] == x)
        return x;

    int t = pre[x];
    pre[x] = findfather(pre[x]);
    dis[x] += dis[t];
    return pre[x];
}

void mix(int x, int y)
{
    int fx = findfather(x);
    int fy = findfather(y);
    pre[fx] = fy;

    dis[fx] += counts[fy];///x到底部的距离加上子集的大小
    counts[fy] += counts[fx];///根集的大小加上子集的大小
    counts[fx] = 0;///清空子集
}

int main()
{
    int p;
    char c;
    int x, y;

    cin >> p;
    for (int i = 1; i <= 30000; ++i)
    {
        pre[i] = i;
        counts[i] = 1;
        dis[i] = 0;
    }
    for (int i = 1; i <= p; ++i)
    {
        cin >> c;
        if (c == 'C')
        {
            int n;
            int mmm;///这个变量的设定就是
            cin >> n;
            mmm = findfather(n);
            printf("%d\n", dis[n]);
        }
        else
        {
            cin >> x >> y;
            mix(x, y);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值