HDU 2846 - Repository

28 篇文章 0 订阅
Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

 
Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s

Sample Output
  
  
0 20 11 11 2
 
题意:先给出一个数字 N,后面 N 行给出 N 个字符串,后面一行给出一个数字 M,后面 M 行字符串,求出每个字符串在前面出现的次数。
是一个字符串的匹配问题,用字典树非常方便,上网看了下模板很快就过了。
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

struct tree
{
    int id;
    int num;
    tree *next[26];
    tree ()
    {
        num = 0;
        id = -1;
        for (int i = 0; i < 26; ++i)
            next[i] = NULL;
    }

};
char s[25];
tree *root = new tree;

void Insert(char str[],int k)
{
    int len=strlen(str);

    tree* cur=root;
    tree* q;
    for(int i = 0; i < len ; i++)
    {
        int x = str[i]-'a';

        if(cur->next[x] == NULL)
        {
            q = new tree;
            q->id = k;
            q->num = 1;
            for(int j = 0; j < 26; j++)
                q->next[j] = NULL;
            cur->next[x] = q;
        }
        cur = cur->next[x];
        if(cur->id != k)
        {
            cur->id = k;
            cur->num++;
        }
    }
}

int Search(char str[])
{
    int len = strlen(str);
    tree *p = root;
    for(int i = 0; i < len; i++)
    {
        int x = str[i]-'a';

        if(p->next[x])
            p = p->next[x];
        else
            return 0;
    }
    return p->num;
}

int main()
{
    int n;
    for(int i = 0; i < 26; i++)
        root->next[0] = NULL;

    root->num = 0;
    root->id = -1;
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        scanf("%s", s);
        int len = strlen(s);
        for(int j = 0; j < len; j++)
        {
            Insert(s + j, i);
        }
    }
    int m;
    scanf("%d", &m);
    while(m--)
    {
        scanf("%s",s);
        printf("%d\n", Search(s));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值