B - Red and Black


  
  

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. '.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


    
    
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
char mp[50][50];
int book[50][50];
int dir[4][2] = { 1,0,0,1,-1,0,0,-1 };
int h, w,st1,st2;
void dfs(int x, int y)
{
	book[x][y] = 1;
	for (int i = 0;i < 4;i++)
	{
		st1 = x + dir[i][0];
		st2 = y + dir[i][1];
		if (st1 >= 0 && st1 < h&&st2 >= 0 && st2 < w&&book[st1][st2] != 1&&mp[st1][st2]!='#')
		{
			book[st1][st2] = 1;
			dfs(st1, st2);
		}
	}
}
int main()
{
	while (1)
	{
		scanf("%d %d", &w, &h);
		if (w == 0 && h == 0)
		{
			break;
		}
		else
		{
			memset(book, 0, sizeof(book));
			int sx, sy;
			for (int i = 0;i < h;i++)
			{
				scanf("%s", mp[i]);
				for (int j = 0;j < w;j++)
				{
					if (mp[i][j] == '@')
					{
						sx = i;
						sy = j;
					}
				}
			}
			dfs(sx, sy);
			int count = 0;
			for (int i = 0;i < h;i++)
			{
				for (int j = 0;j < w;j++)
				{
					if (book[i][j] == 1)
						count++;
				}
			}
			printf("%d\n", count);
		}
	}
	return 0;//byzzk
}



   
   
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值