HDU-1757(矩阵快速幂)

Lele now is thinking about a simple function f(x). 

If x < 10 f(x) = x. 
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10); 
And ai(0<=i<=9) can only be 0 or 1 . 

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m. 
Input
The problem contains mutiple test cases.Please process to the end of file. 
In each case, there will be two lines. 
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9. 
Output
For each case, output f(k) % m in one line.
Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0
Sample Output
45
104
/*
题意:给两个数k和m,然后是10个由0和1组成的数,分别代表a0->a9,求f(k)%m
f(x)定义为:
If x < 10 ,f(x) = x.
If x >= 10 ,f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);

题解:
构建矩阵
| f(10)|       |a0 a1 a2 ...a8 a9|          |f(9)|
| f(9) |       | 1  0  0 ... 0  0|          |f(8)|
| .....|  =    |.. ... ... ... ..|     *    | .. |
| f(2) |       | 0  0  0 ... 0  0|          |f(1)|
| f(1) |       | 0  0  0 ... 1  0|          |f(0)|

*/


#include <stdio.h>
#include <string.h>
#include<iostream>
#include <algorithm>
#include<math.h>
#include<map>
using namespace std;

struct node
{
	int maxtri[12][12];
};
node res, roi;
long long int k, m;

void init()
{
	memset(res.maxtri, 0, sizeof(res.maxtri));
	for (int i = 0; i < 10; i++)
	{
		res.maxtri[i][i] = 1;
	}
	for (int i = 1; i < 10; i++)
	{
		for (int j = 0; j < 10; j++)
		{
			if ((i - 1) == j)
			{
				roi.maxtri[i][j] = 1;
			}
			else
				roi.maxtri[i][j] = 0;
		}
	}
}

node muti(node ss, node tt)
{
	node ans;
	memset(ans.maxtri, 0, sizeof(ans.maxtri));
	for (int i = 0; i < 10; i++)
	{
		for (int j = 0; j < 10; j++)
		{
			if (ss.maxtri[i][j] == 0)
				continue;
			for (int kk = 0; kk < 10; kk++)
			{
				ans.maxtri[i][kk] = (ans.maxtri[i][kk] + (ss.maxtri[i][j] * tt.maxtri[j][kk]) % m) % m;
			}
		}
	}
	return ans;
}

void muti_maxtri(int n)
{
	while (n)
	{
		if (n % 2 != 0)
		{
			res = muti(res, roi);
		}
		roi = muti(roi, roi);
		n /= 2;
	}

}


int main()
{
	while (cin >> k >> m)
	{
		for (int i = 0; i < 10; i++)
		{
			cin >> roi.maxtri[0][i];
		}
		init();
		if (k <= 9)
		{
			cout << k%m << endl;
			continue;
		}
		else
		{
			muti_maxtri(k - 9);
			int sum = 0;
			for (int i = 0; i < 10; i++)
			{
				sum += (res.maxtri[0][i] * (9 - i)) % m;
				sum %= m;
			}
			cout << sum << endl;
		}
	}


	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值