杭电 1087 hdu (Dynamic Programming)Super Jumping! Jumping! Jumping!

杭电 1087 hdu (Dynamic Programming)

Super Jumping! Jumping! Jumping!

*Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66856 Accepted Submission(s): 31301*

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

img

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

刚开始理解错题意,以为是一道求连续递增子序列和的DP问题

但是,经过无数次WA之后终于恍然大悟,本题不要求连续!!!只需要递增就完了

AC代码:


#include<iostream>
#include<algorithm>
#include<vector>
#include<iterator>
using namespace std;

int main()
{
    int N;
    //11-19日记录:最大连续上升子序列
    //11-20日记录:理解错题意
    //本题不要连续
    while(cin>>N && N!=0)
    {
        vector<int> v(N);
        for(int i=0; i<N; i++)
        {
            cin>>v[i];
        }
        vector<long long> sum(N);
        sum[0] = v[0];
        for(int i=1; i<N; i++)
        {
            sum[i] = v[i];
            for(int j=0;j<i;j++)
            {
                if(v[j]<v[i] && v[i]+sum[j] >sum[i])
                {
                    sum[i]=v[i]+sum[j];
                }
            }
        }
//        copy(sum.begin(),sum.end(),ostream_iterator<int>(cout," "));
//        cout<<endl;
        cout<<*max_element(sum.begin(),sum.end())<<endl;

    }
}

下面是错误理解的代码

#include<iostream>
#include<algorithm>
#include<vector>
#include<iterator>
using namespace std;

int main()
{
    int N;
    while(cin>>N && N!=0)
    {
        vector<int> v(N);
        for(int i=0; i<N; i++)
        {
            cin>>v[i];
        }
        vector<long long> sum(N);
        sum[0] = v[0];
        for(int i=1; i<N; i++)
        {
            if(v[i]>v[i-1]) //递增
            {
                sum[i] = max(sum[i-1]+v[i],(long long)v[i]);
            }
            else
            {
                sum[i] = v[i];
            }
        }
//        copy(sum.begin(),sum.end(),ostream_iterator<int>(cout," "));
//        cout<<endl;
        cout<<*max_element(sum.begin(),sum.end())<<endl;

    }
}

以后要好好读题,认真理解题意,少走许多弯路.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值