Red and Black

  题目描述:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.  

Input:
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

output:

   * For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).   

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
  
  
   
   Sample Output
  
  
  
  
45
59
6
13
题解:题目读了就能懂,就是搜索能达到的点。
解题思路:每搜索一个能到的点就记录下来并标记它(为了不重复搜索到已经搜索过的点以致答案错误),最后输出答案就行。
AC代码:
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
int m,n;
	char map[30][30];
	int dr[4][2]={1,0,-1,0,0,1,0,-1};  //上下左右四个方向
	int bj[30][30];   //标记搜索过的点的数组
	struct st  //记录点的坐标
{
	int x;
	int y;
 };
int bfs(int a,int b)
{
	int i,cmp=1;
   memset(bj,0,sizeof(bj));//将bj数组初始化为0
   queue<st> qu;  
   st now,Next;
   	now.x=a,now.y=b;
   	qu.push(now);
   	bj[a][b]=1;     //标记初始点
   	while(!qu.empty())
   	{
   		now=qu.front();  //取出搜索基点
   		qu.pop(); //把搜索基点弹出队列
   		for(i=0;i<4;i++)  //搜索上下左右四个点
   		{
   			int dx=now.x+dr[i][0];
   			int dy=now.y+dr[i][1];
   			if(map[dx][dy]=='.'&&dx>=0&&dx<n&&dy>=0&&dy<m&&bj[dx][dy]==0) //判断该点是否为未搜索过的可到点
   			{
   				cmp++;
   				bj[dx][dy]=1;
   				Next.x=dx;
   				Next.y=dy;
   				qu.push(Next);
			   }
		   }
	   }
	   return cmp;
}
 int main()
 {
 	int i,j,sum,a,b;
 	while(scanf("%d%d",&m,&n)!=EOF)
 	{
 		if(m==0&&n==0)
 		break;
 		for(i=0;i<n;i++)
 		{
 			scanf("%s",map[i]);
 			for(j=0;j<m;j++)
 			{
 			if(map[i][j]=='@')
 			a=i,b=j;
 		}
 		}
		sum=bfs(a,b);
		printf("%d\n",sum);
	}
	 return 0;
 }

  
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值