PAT甲级1132和1136解题报告

49 篇文章 0 订阅
47 篇文章 0 订阅

1132 Cut Integer (20 point(s))

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

题目大意:每次输入一个数,如果这个数对半分开两个数相乘能被原来的数整除,那么输出yes反之no。

解题思路:就拆成两个数除一下,注意考虑出现某个数是0的情况。

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
int main()
{
	int N;
	scanf("%d", &N);
	while (N--) {
		int b;
		scanf("%d", &b);
		string a = to_string(b);
		bool flag = false;
		string s1 = a.substr(0, a.size() / 2);
		string s2 = a.substr(a.size() / 2);
		if (atoi(s1.c_str())*atoi(s2.c_str()) != 0 && b % (atoi(s1.c_str())*atoi(s2.c_str())) == 0) {
			flag = true;
		}
		if (flag)printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}

1136 A Delayed Palindrome (20 point(s))

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

题目大意:输入一个数将这个数正着倒着不断相加直到这个数是个回文的,如果10次还没回文,那就拉闸。

解题思路:模拟一下大数相加,没什么花头。

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
bool judge(string a) {
	string b = a;
	reverse(b.begin(), b.end());
	if (a == b)return true;
	else
		return false;
}
string add(string a) {
	string res;
	string b = a;
	reverse(b.begin(), b.end());
	int tot = 0;
	for (int i = a.size()-1; i >=0; i--) {
		int cur = (a[i] - '0') + (b[i] - '0')+tot;
		res.push_back((cur % 10)+'0');
		tot = cur / 10;
	}
	if (tot != 0) {
		res.push_back(tot+'0');
	}
	reverse(res.begin(), res.end());
	return res;
}
int main()
{
	string a;
	cin >> a;
	bool flag = true;
	for (int i = 0; i < 10; i++) {
		if (!judge(a)) {
			string b = a;
			reverse(b.begin(), b.end());
			cout << a << " + " << b << " = " << add(a) << endl;
			a = add(a);
		}
		else {
			flag = false;
			cout << a << " is a palindromic number." << endl;
			break;
		}
	}
	if (flag) {
		cout << "Not found in 10 iterations." << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值