HDU 5202 Rikka with string (水DFS)

66 篇文章 0 订阅


Rikka with string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 624    Accepted Submission(s): 243

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:


One day, Yuta got a string which contains n letters but Rikka lost it in accident. Now they want to recover the string. Yuta remembers that the string only contains lowercase letters and it is not a palindrome string. Unfortunately he cannot remember some letters. Can you help him recover the string?


It is too difficult for Rikka. Can you help her?
 
Input
This problem has multi test cases (no more than 20 ). For each test case, The first line contains a number n(1n1000) . The next line contains an n-length string which only contains lowercase letters and ‘?’ – the place which Yuta is not sure.
 
Output
For each test cases print a n-length string – the string you come up with. In the case where more than one string exists, print the lexicographically first one. In the case where no such string exists, output “QwQ”.
 
Sample Input
  
  
5 a?bb? 3 aaa
 
Sample Output
  
  
aabba QwQ
 
Source
BestCoder Round #37 ($)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5202

题目大意:问号处填字母要求字典序最小且非回文

题目分析:遇到问号搜一下,字母从a到z枚举,搜完一组判断是否是回文,不是就退出,否则回溯继续搜

#include <cstdio>
#include <cstring>
char s[1005];
int n;
bool flag;

bool ok()
{
    for(int i = 0; i < n / 2; i++)
        if(s[i] != s[n - i - 1])
            return true;
    return false;
}

void DFS(int pos)
{
    if(pos == n)
    {
        if(ok())
            flag = true;
        return;
    }
    if(s[pos] != '?')
    {  
        DFS(pos + 1);
        if(flag)
            return;
    }
    else
    {
        for(char j = 'a'; j <= 'z'; j++)
        {
            s[pos] = j;
            DFS(pos + 1);
            if(flag)
                return;
            s[pos] = '?';
        }
    }
    return;
}

int main()
{
    while(scanf("%d", &n) != EOF)
    {
        flag = false;
        scanf("%s", s);
        DFS(0);
        if(flag)
            printf("%s\n", s);
        else
            printf("QwQ\n");
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值