HDU 5326 Work (基础树形dp)


Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 27    Accepted Submission(s): 19

Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.
 
Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.
1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 
Output
For each test case, output the answer as described above.
 
Sample Input
  
  
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 
Sample Output
  
  
2
 
Source
2015 Multi-University Training Contest 3

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5326

题目大意:给一个树,点之间是雇佣关系 A B表示A是B上司,问有几个人有k个下属

题目分析:多校签到,随便算一下


#include <cstdio>
#include <cstring>
int const MAX = 105;
struct EDGE
{
    int v, next;
}e[MAX];
int head[MAX], num[MAX];
bool in[MAX], vis[MAX];
int cnt, ans;
int n, k;

void Add(int u, int v)
{
    e[cnt].v = v;
    e[cnt].next = head[u];
    head[u] = cnt ++;
}

void DFS(int u)
{
    vis[u] = true;
    num[u] = 0;
    for(int i = head[u]; i != -1; i = e[i].next)
    {
        int v = e[i].v;
        if(!vis[v])
        {
            DFS(v);
            num[u] += (num[v] + 1);
        }
    }
    if(num[u] == k)
        ans ++;
    return;
}

int main()
{
    while(scanf("%d %d", &n, &k) != EOF)
    {
        cnt = 0;
        ans = 0;
        memset(head, -1, sizeof(head));
        memset(in, false, sizeof(in));
        memset(vis, false, sizeof(vis));
        for(int i = 0; i < n - 1; i++)
        {
            int u, v;
            scanf("%d %d", &u, &v);
            Add(u, v);
            in[v] ++;
        }
        for(int i = 1; i <= n; i++)
            if(in[i] == 0)
                DFS(i);
        printf("%d\n", ans);
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值