区间覆盖_zoj_

以前 这种题都是先结构体二级排序,然后用贪心的算法遍历寻找,今天见了这个代码,眼前一亮,大牛果然是大牛

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3197


ZOJ Problem Set - 3197
Google Book

Time Limit: 1 Second       Memory Limit: 32768 KB

You, the best hacker in the world, want to download the books published on Google Book. After some investigation, you found that the address of each page consists of two parts. The first part is the page number, the second part is the signature which is unique for each page. To get the signature, you can send the query to the server. The query has one parameter, which indicates the page number. The server will return the signature of the required page, and it may also return the signature of some adjacent pages.

To minimize the bytes downloaded from the internet, and also make the server adminstrator hard to notice your "hack", you'd like to minimize the number of queries

Input

The input has multiple cases.
The first line of the input is a single integer T which is the number of test cases. Then T consecutive test cases follow. In each test case, the first line is a number N (1<=N<=5000), indicating the number of pages of the book. Then n lines follows. On the i-th line, there will be two integers ai and bi (ai<=i<=bi). They indicate that the query for the i-th page will return the signatures from page ai to page bi (inclusive)

Output

Results should be directed to standard output. The output of each test case should be a single integer, which is the minimum number of queries to get all the signatures.

Sample Input

2
3
1 1
2 2
3 3
3
1 1
1 3
3 3

Sample Output

3
1


代码:
#include <stdio.h>
#include <string.h>

define MAX 5050
int a[MAX], b[MAX];

int main()
{
    int n, i, j, x, y, count, T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        memset(a, 0, sizeof(a));

        for ( i = 1; i <= n; i++)
        {
            scanf("%d %d", &x, &y);
            if (a[x] < y)
            {
                a[x] = y;
            }
        }/**数组a内存储以x为起点,结束时间的最大值**/

        for (b[1] = a[1], j = 2; j <= n; j++)
        {
            if (b[j - 1] > a[j])
            {
                b[j] = b[j - 1];
            }
            else
            {
                b[j] = a[j];
            }
         }/**b[i]记录a[1]-a[i]中的最大值,递归关系b[i]=max(b[i-1],a[i]);b[1]=a[1];**/

        for (count = 0, y = 1; y <= n; count++)
        {
            y = b[y] + 1;
        }/**合并区间,计数**/

        printf("%d\n", count);
    }
    return 0;
}

运行结果:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值