【POJ】poj 1157 (DP)

 

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 

 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

723-5-2416

2 (begonias)

521-41023

3 (carnations)

-21

5-4-2020


According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

Input

  • The first line contains two numbers: FV.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.

 


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
  • F <= V <= 100 where V is the number of vases. 
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

 

这个题目是一个动态规划的问题,先定义一个二维数组,表示第i束花插在第j个花瓶上的最大价值,那么就可以得到状态方程

 

f [ i ] [ j ] = for ( k = i ,k < j ) max ( f [ i ] [ j ], maxvaule [ i - 1 ] [ k ] + value [ i ] [ j ] ; 在最后扫描数组最后一行可以得到最佳结果

代码如下:

 

#include<iostream>
#include<cstring>
using namespace std;
int flower,vase;
int aesthetic[105][105];
int maxaes[105][105];/**表示在第i个花放第j个位置的最大的美观程度*/
int main()
{
    while ( cin >> flower >> vase )
    {
        for ( int i = 0; i < flower; i++ )
        {
            for ( int j = 0; j < vase; j++ )
            {
                cin >> aesthetic[i][j];
            }
        }
        for ( int i = 0; i < flower; i++ )
        {
            for ( int j = i; j < vase; j++ )
            {
                if ( i == 0)
                    maxaes[i][j] = aesthetic[i][j];/**如果是第一个花的话就是输入的美观值*/
                else
                {
                    for ( int k = i - 1; k < j; k++ )
                    {
                        if ( maxaes[i][j] < maxaes[ i - 1 ][ k ] + aesthetic[i][j] )/**可以采用01滚动,可以节约空间*/
                            maxaes[i][j] = maxaes[ i - 1 ][ k ] + aesthetic[i][j];
                    }
                }
            }
        }
        int ans = -10000;
        for ( int i = vase - flower; i < vase; i++ )
        {
            if ( ans <  maxaes[ flower - 1 ][ i ] )/**找出插入最后一朵花的最大值*/
                ans =  maxaes[ flower - 1 ][ i ];
        }
        cout << ans << endl;
    }
}

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值