How Many Answers Are Wrong(带权并查集)

TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)


InputLine 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
OutputA single line with a integer denotes how many answers are wrong.Sample Input

10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1

Sample Output

1

题意:有两个人一个叫TT的男孩一个叫FF的女孩,这个叫TT的男孩会经常叫这个女孩一起玩一个游戏,这个有些是这样的,随便写一个数列,现在TT会选择一个区间,然后让FF计算这个区间里面所有数的和,这是一个非常非常无聊的游戏,于是FF准备捉弄一下TT,有时候她会故意计算出来一个错的答案,当然TT也比较聪明,他会发现这个答案跟以前的答案会有冲突,那么问题来了,有多少话是假的呢???输入 第一行为区间总长度n和询问次数m。下面有m行,每一行三个数,分别为a、b、c,代表所选区间(a,b),c为FF给出答案。
思路:用并查集合 存放a,b端点所能到达的最左边的端点f1,f2,设a的根结点为f1,b的根结点为f2,sum[a]则表示区间(f1,a)中所有数的和,sum[b]同理。若f1=f2,则判断一下sum[b]-sum[a]和c是否相等,若不相等则更新并查集合与sum集合。

#include<stdio.h>
int n,m,a,b,c;
int pre[2000005];
int sum[2000005];
int find(int x)
{
    int k=pre[x];
    if(pre[x]!=x)
    {
        pre[x]=find(pre[x]);
        sum[x]+=sum[k];
    }
    return pre[x];
}
void Merge(int f1,int f2,int a,int b,int c)
{
    if(f1>f2)
    {
        pre[f1]=f2;
        sum[f1]=sum[b]-sum[a]-c;
    }
    else
    {
        pre[f2]=f1;
        sum[f2]=sum[a]-sum[b]+c;
    }
}
int main()
{
    int i,j;
    int ans;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=0;
        for(i=0;i<=n;i++)
        {
            pre[i]=i;
            sum[i]=0;
        }

        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            a--;//必须有a--或者有b++

            int f1=find(a);
            int f2=find(b);

            if(f1==f2 && sum[a]+c!=sum[b])
                ans++;

            else if(f1!=f2)
            {
                Merge(f1,f2,a,b,c);
            }
        }
        
        printf("%d\n",ans);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值