网络安全基础笔记

网络安全基础笔记

提示:这里可以添加系列文章的所有文章的目录,目录需要自己手动添加
例如:第一章 Python 机器学习入门之pandas的使用


提示:写完文章后,目录可以自动生成,如何生成可参考右边的帮助文档

文章目录


一.IP地址

1.交换机:用来组建内网的局域网设备
路由器:用来连接内网和外网
在这里插入图片描述
简单局域网的构成:交换机,网线,PC
局域网:一般称为内网

2.ip地址正确性的范围:

0-255 
0.0.0.0~255.255.255.255

3.在同一个局域网中,所有的IP必须在同一网段中才能互相通信

4.子网掩码:用来确定ip地址的主机位

255.0.0.0
255.255.0.0
255.255.255.0

5.地址详解

A类:1 - 126 默认子网掩码:255.0.0.0
B类:128-191 默认子网掩码:255.255.0.0
C类:192-223 默认子网掩码:255.255.255.0
D类:224-239组播地址
E类:240-254科研使用

6.一个ip地址分为网段+主机名
例:20.3.5.8 && 255.255.255.0
根据子网掩码,前三位为网段,后一位为主机名
20.3.5.0~20.3.5.254属于同意网段,因此可通信
20.3.5.255为广播地址

7.127.0.0.1 为回环地址,测试自己的网络

8.网关Gateway (GW)
网关 PC向外发包:
首先判断目标IP地址与自己是否在同一网段
如在同一网段,则直接发出去,而不找网关
如不在同一网段,则直接发包给网关

9.DNS-域名解析服务
在这里插入图片描述

虚拟交换机实验

通过虚拟交换机连接两个虚拟机
step 1:配置虚拟交换机
打开hyper v,选择虚拟交换机管理器
在这里插入图片描述

创建虚拟交换机

  • 内部:适用于物理主机与虚拟机,虚拟机与虚拟机之间的本机连接
  • 外部:适用于与外部Internet的连接

在这里插入图片描述

在这里插入图片描述
step2:在两个虚拟机里设置选择刚刚配置的网络适配器vmnet1
在这里插入图片描述
step3:给两个虚拟机配ip地址
WIN7 控制面板->网络和Internet->查看网络状态和任务->更改适配器设置->右键点击本地连接->属性
在这里插入图片描述
弹出的属性窗口双击TCP/IPv4手动配置IP 10.1.1.2
在这里插入图片描述
同理WIN XP:开始菜单->我的电脑->网上邻居->查看网络连接->本地连接->右键点击属性
配ip 10.1.1.3

step 4:关闭两台虚拟机的防火墙!!!!
我之前ping了半天一直显示time request out!!!和目的主机访问不通就是因为没关防火墙

win7、win xp 开始->控制面板->系统和安全->Windows防火墙->打开或关闭防火墙
在这里插入图片描述
step 5:环境测试
在这里插入图片描述
测试成功!!!

1.环境配置

cmd.exe的路径C:\Windows\System32
否则屏幕会显示系统无法在消息文件中为 Application 找到消息号为 0x2350 的消息文本

2. dir

显示目录文件和子目录列表,但是不对子目录递归。

/p 每次以一个屏幕大小显示列表的一部分。要查看下一屏,请按键盘上的任意键。

/q 显示文件所有权信息。 (哪些用户是文件的拥有者)

/w 以宽格式显示列表,在每一行上显示多个文件名或目录名(这时只显示文件和目录的名字,不显示其完整路径,且目录用中括号[]起来,比如[work]。这时如果当前目录不是磁盘的根目录的话,显示目录还会包含当前目录和上级目录:[.]和[…]

/d 与 /w 相似,但是文件按列排序。

/a [[:] Attributes]
只显示那些指定属性的目录名和文件名。如果省略 /a,dir 将显示除隐藏文件和系统文件之外的所有文件名。如果在没有指定 Attributes 的情况下使用 /a,dir 将显示所有文件(包括隐藏文件和系统文件)的名称。以下列表描述了每个可用于 Attributes 的值。冒号 (😃 是可选的。使用这些值的组合,不得用空格分隔这些值,直接挨着就行了。

比如:/a:r-h。
值描述
h 隐藏文件
s 系统文件
d 目录
a 可以存档的文件
r 只读文件
-h 非隐藏的文件
-s 系统文件以外的文件
-d 只是文件(而非目录)
-a 自上次备份后没有更改过的文件
-r 非只读的文件

/o[[:]SortOrder]
控制 dir 排序和显示目录名和文件名的顺序。如果省略 /o,dir 将按名字的字母顺序来显示。如果在没有指定 SortOrder 的情况下使用 /o,dir 先显示按字母顺序排列的目录名,然后显示按字母顺序排列的文件名。冒号 (😃 是可选的。以下列表描述了每个可用于 SortOrder 的值。使用这些值的任意组合,并且不要用空格分隔这些值。
值描述
n 按名称的字母顺序
e 按扩展名的字母顺序
d 按日期和时间,最早的优先
s 按大小,最小的优先
g 在文件之前分组的目录
-n 按名称的逆序字母(从 Z 到 A)顺序
-e 按扩展名的逆序字母(从 .ZZZ 到 .AAA)顺序
-d 按日期和时间,最晚的优先
-s 按大小,最大的优先
-g 在文件之后分组的目录

/t[[:]TimeField]
指定显示或用于排序的时间字段。以下列表描述了每个可用于 TimeField 的值。

如果有/o参数但没d属性时只用于指定显示的时间字段,如果有/o参数且属性或没有/o参数时,既是指定了排序的时间字段也是指定显示的时间字段
值描述
c 创建

a 上次访问
w 上次写入

/s 在指定目录及所有子目录中遍历,如果没给该参数不会在子目录遍历

/b 列出每个目录名或文件名,只有名字(文件的话包含文件扩展名),每行一个,不显示标题信息或摘要。如果它和/s组合的话,显示的文件和目录都是完整的路径的形式。
/l 以小写字母形式显示目录名和文件名。

/n 在屏幕最右边显示带有文件名的长列表格式。

注:XP中,该选项好像是默认行为。

/x 显示为 NTFS 和 FAT 卷上文件生成的短名称。短名称显示在长名称之左侧。

/c 按文件大小显示多个分隔符。

“DIR/-C”将取消显示中的分隔符,以满足部分人的视觉习惯。

注:XP中,该选项默认行为是/c,即显示多个分隔符。

/4 显示四位数字的年份格式。
注:XP中,该选项好像是默认行为。

3. echo 输出

echo world is very well>qingshu.txt

//将world is very well 打印到qingshu.txt文件中

@echo off

//表示关闭执行过程

4.ping

//“ping”可以检查网络是否连通,可以很好地帮助我们分析和判定网络故障

//>nul表示不显示ping的结果,但是不能隐藏错误信息。 2>null表示隐藏错误信息。

5.type

type 文件名.拓展名|more
// |more表示分页.

6 ipconfig

可以看出电脑现在的ip

7.netstat -an

可以查看电脑都开了哪些端口号,有哪些服务开启

三、批处理命令

1.创建批处理命令

新建个记事本,手动将拓展名改为.bat
在这里插入图片描述
如果想要编辑,就按图所示:在这里插入图片描述

2.实例

2.1 打印

@echo off //清除执行过程,只显示结果
title password //程序标题
color 0a //文字变成绿色
echo ========
echo i am cc
echo ========
pause

在这里插入图片描述

2.2 清理垃圾

@echo off
color 0a
title clear laji program
echo ========
echo clear your system laji
echo if beilanjie
echo please fangxing
echo ========
pause
echo.

echo laji is cleaning

d: >nul 2>nul //不返回指令结果
cd \ >nul 2>nul //不返回指令结果
rd. /s /q   

ping -n 10 127.0.0.1 >nul 2>nul 

echo congratulations!!!
pause //停下查看返回结果

ps:
rd 可以删除空目录
rd /s /q可以删除非空目录

例如:

rd c:\hello

如果c:\hello中还有文件,那么这样是删除不了的,必须rd /s /q c:\hello

2.3 创建文件——导致空间资源不足

注意:导致系统奔溃的一个原因还有可能是空间不足,如果创建文件足够大的话

f:
cd\   //返回根目录
fsutil file createnew f:\sys.ini 1024000000
fsutil file createnew f:\sys1.ini 1024000000

原来F盘有这么多存储空间,在这里插入图片描述
双击执行bat文件以后(fsutil要求您有管理权限,以管理员身份运行):
就会产生如下文件
在这里插入图片描述
在这里插入图片描述
继续刚才那个垃圾清理案例,把刚刚创建的文件删掉

2.4 最简单的病毒

// 带特殊符号需要用双引号“”
// %userprofile% 变量
copy qq.bat "%userprofile%\[开始]菜单\程序\启动" 
:d      //分区d
start   //开启命令窗口
goto d  //去d分区

会陷入死循环,使电脑死机

2.5 小程序—分区应用

@echo off
title 飞鸽小程序 v1.0
color 0a

:menu
echo ====================
echo      菜单
echo  1.定时关机
echo  2.取消定时
echo  3.退出
echo ====================

set /p num=您的选择是:

if"%num%"=="1" goto 1
if"%num%"=="2" goto 2
if"%num%"=="3" goto 3

echo 只能输入123
goto menu

:1
 set /p a=请输入时间(单位/秒):
 shutdown -s -f -t  %a%  //a代表变量:用户自己输入多长时间之后关机
 goto menu
:2 
 shutdown -a
 goto menu
:3 
 exit
 goto menu

2.6 针对xp或2003 的蓝屏操作

ntsd -c q -pn winlogon.exe

2.7 杀死进程

taskkill /im explorer.exe/f

三、用户管理

1.基础

  • 每个用户登录系统后,拥有不同的权限,给不同的用户赋权限,也即是给不同的SID赋权限

  • 每个账户有一个唯一的SID(安全标识符)

  • 一般Windows系统管理员的UID是500

  • 普通用户的UID聪1000开始

  • 账户密码的位置存放:
    -C:\windows\system32\config\SAM 不可逆哈希加密算法 只能暴力破解和撞库
    -默认密码最长期限42天

  • 内置账户:
    给人使用的:

        administrator管理员账户
        guest 来宾账户
    

    计算机服务组件相关的系统账户:

         system                 系统账户,权限至高无上
         local service          本地服务账户
         network service        网络服务账户
    

在这里插入图片描述
权限高低:system>administrator>两个service>guest

  • 配置文件:每个用户都有自己的配置文件userprofile
   路径: C:\用户

2.用户管理指令

net user //查看有哪些账户
net user 用户名 //查看用户详细信息
net user abc 123 /add //新建一个用户abc,密码123 ,只有administrator有权限
net user abc /del //删除用户
net user 用户名 /active:yes/no

如何以管理员身份登录

在这里插入图片描述

3.组:简化权限

1.给一个组的所有成员赋予同等权限
2.内置组——权限默认已被系统赋予

  • administrators 管理员组
  • guests 来宾组
  • users 普通用户组
  • network 网络配置组
  • print 打印机组
  • remote desktop远程桌面组

3.组管理命令

net localgroup
net localgroup CEO /add //添加组CEO
================================
net user abc /add    //添加用户abc
net localgroup administrators abc /add //添加abc用户到管理员组
net localgroup administrators  //查询管理员组成员
net localgroup administrators abc /del  //从管理员组删掉abc

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

四、服务器远程管理(win7远程控制win xp)

图形化远程管理&命令行远程管理(telnet

1.图形化远程管理

需要知道:对方ip,用户账号,密码

step 1:配置虚拟交换机,并且使两个虚拟机能够ping通
step 2:
win xp的IP为: 10.1.1.3
win7的IP为: 10.1.1.2
win xp: 开始菜单-我的电脑-右键点击属性-上方选择远程-选择“允许用户远程连接到计算机”
在这里插入图片描述
win 7 开始-运行-mstsc 或者 直接打开“远程桌面连接
在这里插入图片描述
弹出远程桌面连接窗口,输入:win xp的IP在这里插入图片描述
此时,就可以登录了在这里插入图片描述
因为管理员不想让你用administrator账号登录,因此会给你另设一个账号,从windows XP(被远程控制的电脑)命令行输入

net user a a /add

新建账号a,密码a
登录win xp,发现a没有远程权限,因此给a开设一个远程权限
依然使刚才那个界面,选择远程用户-添加-在对象中输入a-点击确定在这里插入图片描述
到此,win7就可以以用户a的身份登录远程win xp了

2.telnet协议——以明文形式存储

step1.先把两台机器ping通
step2. win xp和win xp 开始-运行-输入“services.msc”/开始-计算机-右键点击管理
出现的问题:没找到telnet服务协议!!!
解决办法
之后在打开的窗口中双击Telnet,选择自动,点击应用,再点击启动在这里插入图片描述
step 3 把需要被远程控制的win xp的账户a加入进TelnetClients组中去
开始-我的电脑-右键管理-用户和组-添加
在这里插入图片描述
step 4: win7命令行输入

telnet 10.1.1.3 //win xp的ip地址为10.1.1.3

命令行显示:在这里插入图片描述
输入n
在这里插入图片描述
接下来输入账号密码
在这里插入图片描述
下面输入的命令就是对被控制机器win xp的命令了
点击exit推虎控制

3. 查看本机开放的左右端口号——一个端口号对应一个服务协议

netstat -an //查看本机开放的所有端口号

telnet:23
远程桌面RDP(Remote Desktop Protocol):3389

五、破解系统密码

5.1 通过5次shift键破解系统密码——只适用于存在漏洞的系统

1.基本了解

  • 用户、密码所在位置 C:\Windows\System32\config\SAM
  • 修改用户密码 net user 用户名 新密码
  • 粘滞键所在位置为:C:Windows\System32\sethc.exe

2.步骤

i. 开机
断电再开机,出现如下屏幕,点击启动修复:
在这里插入图片描述
出现如下:
在这里插入图片描述
ii. 过几分钟,会问你是否还原系统,点击取消
再过几分钟,系统无法修复,会弹出如下消息框,点击查看问题详细信息
在这里插入图片描述
出现如下,点击隐私声明那个C盘下的目录:在这里插入图片描述
iii.在弹出来的txt文档中点击打开:
在这里插入图片描述
iv.
原始的
粘滞键所在位置为:C:Windows\System32\sethc.exe
在这里插入图片描述

打开隐私声明文件中的文件位置,把C盘下的粘滞键改名(什么名字都可以),这里改成feifei在这里插入图片描述
v.再把cmd.exe复制一份cmd-副本,改名成sethc
在这里插入图片描述
vi.再关闭窗口点击完成,重新启动
在这里插入图片描述
vii.最后在登录页面连按5次shift键,本来应该出现粘滞键
在这里插入图片描述
实际出现cmd窗口,再输入命令完成密码修改:

 net user shimisi ""  //shimisi账户密码清空

在这里插入图片描述

5.2 利用PE系统破解密码

1.思路介绍

BIOS系统:开机的时候由BIOS系统指定使用哪个硬盘(C、D、E)进行系统的登入等

PE系统:相当于一个微型操作系统,放在U盘里。

原理:一般开机的时候,bios系统会启动决定先启用哪个硬盘进行操作系统的运行,默认先走C、D、E盘查看其中是否有操作系统,如果有的话先进行操作系统的运行开启。之后,电脑开启就会对新插入的U盘进行各种操作包括格式化。

破解系统密码就是在U盘中内置一个PE小型操作系统,插入电脑,等到开机的时候进入BIOS模式调节哪个硬盘先开启运行操作系统,这里我们让U盘先开启运行PE系统,就相当于电脑内置的C、D、E盘属于U盘了,角色互换,这个时候PE系统就可以对C、D、E盘进行格式化了

在这里插入图片描述

六、NTFS权限

1.NTFS基础

  • 实现不同的用户对文件具有不同的权限
  • 设置正确的权限,用户才能访问其资源
  • 防止资源被删除、篡改

2.文件系统概述

在外部存储设备上组织文件的方法,常用的有:

  • FAT windows
  • NTFS windows
  • EXT Linux

Win7系统下的文件系统:
在这里插入图片描述

3.NTFS优点

i.提高磁盘读写性能
ii.可靠性

  • 加密文件系统
  • 访问控制列表

iii.磁盘利用率

  • 压缩
  • 磁盘配额

iv.支持单个文件大于4G

4.设置文件权限

找到F盘,点击属性在这里插入图片描述
从属性中选择安全在这里插入图片描述
完全控制:拥有读取,写入,删除,修改以及其他特殊的权限
修改:拥有读取,写入,删除,修改等权限
其他字面理解即可

ps:对不同用户进行权限界定的时候,要看清该用户是否还在其他组里,比如用户a还在users中,那么a的权限会是a和users权限的加总。(权限累加)

5.例子

5.1 部分权限降级

假设a属于IT组,拥有超高的文件操作权限,现在部门想对A降低对文件夹的权限,而保留其他权限,做法如下:

进入文件夹属性中找到安全,单独对a设置拒绝权限

对IT组设置权限如下:在这里插入图片描述

对a设置权限如下:在这里插入图片描述
则最后将会导致a无法访问F盘!!!
在这里插入图片描述
因为拒绝和允许累加在一起会导致拒绝的权限更高,总之,拒绝最大

5.2 administrator获取高级权限

假设a自己创建了一个拥有至高无上权限的文件a的专属文件,并且取消了administrator的继承权(即和a拥有相同权限的权利),administrator如何获取权限???

a通过高级安全设置取消继承权,在图中点击删除
在这里插入图片描述
在这里插入图片描述

登录administrators系统,点击a的专属文件,弹出,点击继续:
在这里插入图片描述
按如下方式点击:在这里插入图片描述
至此,管理员就获取a的专属文件的所有权并且可以打开了

七、文件共享服务器(CIFS)——类似于FTP服务器

例子:将win7的F盘public文件共享到win xp
1.右键点击public文件-属性-共享,然后根据权限添加增删用户,如下权限等级由高到低为:完全控制>更改>读取
在这里插入图片描述在这里插入图片描述

访问:登入win xp系统,打开开始菜单-运行-输入10.1.1.2(win 7 IP)
在这里插入图片描述

出现问题:无法访问,您可能没有权限使用网络资源。请与这台服务器的管理员联系以查明您是否有访问权限

解决方法

考虑:

  • 是否同一网段
  • 是否关闭防火墙
  • 是否启用来宾账户

八、DHCP部署及防御

1.相关概念

  • DHCP——dynamic host configure protocol
  • 自动分配IP地址
  • DHCP相当于一个地址池、作用域,一个地址池需要四大元素(子网掩码,网关,IP,DNS)还需要租期
  • 优点:减少工作量,避免IP 冲突,提高地址利用率

2.DHCP工作原理——DHCP租约过程

1)客户机发送DHCP Discovery广播包
客户机广播请求IP地址(包含客户机的MAC地址)
2)服务器响应DHCP Offer广播包
服务器响应提供的IP地址(但无子网掩码、网关等参数)
3)DHCP发送DHCP Request广播包
客户机选择IP,相当于使用哪个IP
4)服务器发送DHCP ACK广播包
服务器确定了租约,并且提供网卡,详细参数,IP,网关,子网掩码等等

3.DHCP续约

当客户机已经被分配IP地址的时候:
1)50%租期过后,客户机向服务器会发送Request包
2)服务器会回复客户机发送ACK包
3) 如果服务器没有回复,则客户机会直接释放IP地址,并且重新发送DHCO Discovery广播包重新获取IP地址
4)当无任何服务器响应时,自动给自己分配一个169.254.X.X/16

租期一般依场景而定,比如:

  • 在KFC,火车站等等人流量比较大的地方,租期较短
  • 在银行,工作场景,一般租期较长,减轻服务器压力

4.DHCP部署

1)DHCP端口号:UDP 67/68
2)DHCP 部署
DHCP部署
启动服务器后,输入:

netstat -an

出现udp 67,68,显示启动成功

在这里插入图片描述
3)实验
step 1
win xp和win server 2006两台虚拟机连接到同一交换机,vmnet1

step 2
开启DHCP服务器,开始-运行-services.msc-DHCP server -右键运行
并且用cmd.exe输入netstat -an查看udp67,68是否开启

step 3
配置DHCP服务器信息(作用域,DNS IP,租约等等)
配置以后可以查看:

-分发的作用域是10.1.1.21-10.1.1.250在这里插入图片描述
-默认网关为10.1.1.254在这里插入图片描述
step 4 打开win7,win xp,可以看到win7和win xp自动获取到IP地址分配信息
在这里插入图片描述
在这里插入图片描述
然后从windows server 2006中可看到两台计算机的连接情况
在这里插入图片描述

**几条命令

ipconfig /查看IP
ipconfig /all 查看ip详细信息
ipconfig /release 释放ip、取消租约、手动配置ip
ipconfig /renew  有ip时,发送request续约,无ip时,发送request重新申请ip

如图,从win 7系统输入以下命令
在这里插入图片描述
在这里插入图片描述

保留的作用

保留,就是DHCP服务器为特定的电脑(MAC)预留一个特定的IP地址

首先,DHCP服务器新建一个保留
在这里插入图片描述
配置保留的相关信息

1)输入ipconfig /all查看win 7的物理地址(MAC地址)
在这里插入图片描述
2)为win7添加保留,从win server的DHCP保留中输入win7的MAC地址,配置10.1.1.33
在这里插入图片描述
最后,先禁用,后启动网络连接,然后从win7终端中输入ipconfig可以看出win7的ip变为10.1.1.33
在这里插入图片描述

备份和还原

针对DHCP部署的ip地址范围,租约等等的备份,防止服务器被格式化之无法重新恢复在这里插入图片描述

将备份文件存入一个桌面,再右键点击还原,可以将文件还原

选项优先级

作用域选项>服务器选项
ps:当服务器上有多个作用域时,可以在服务器选项上设置DNS服务器

注意

  • DHCP服务器比须要静态IP地址
    -网络适配必须在同一网段,而且不勾选LAN
    在这里插入图片描述

5.DHCP攻击与防御

1)
攻击DHCP服务器:频繁的发送伪装DHCP 请求,直到DHCP地址池耗尽
防御:在交换机的端口上,做动态地址MAC绑定
2)
伪装DHCP服务器攻击:黑客将自己部署为DHCP服务器,为客户机提供非法ip
防御:在交换机上,除合法的DHCP所在接口外,禁止发送DHCP offer 包

九、域名解析服务器DNS部署

1.基础

1.1.域名组成

主机名.域名
ex:
比如 www.sina.com.cn,其中www为主机名,sina.com.cn为域名

终端输入

nslookup www.sina.com.cn

就会弹出新浪网的服务器IP,也就是主机名,www
在这里插入图片描述

1.2.结构——树形结构

在这里插入图片描述
ps:根域(也就是最后一个点)前面的域名就是顶级域名
在这里插入图片描述

1.3监听端口

  • TCP 53
  • UDP 53

1.4 DNS解析种类

1.4.1

  • 递归解析:客户机与本地DNS服务器之间
  • 迭代查询:本地DNS服务器与根等其他DNS服务器的解析过程
    在这里插入图片描述

查询访问过程:客户机想要访问网站,先看有没有缓存,没有就访问DNS,DNS会查看是否有缓存,如果有缓存返回给客户机,如果没有,则DNS会访问根域,根域告诉DNS他的下一级域名(.com)的ip,com继续返回DNS告诉下一级域名,依次迭代。。。。

1.4.2 按照查询内容分类

  • 正向解析:已知域名,解析IP地址
  • 反向解析:已知IP地址,解析域名

2.DNS部署

2.1 DNS部署

ps:主要区域与辅助区域,辅助区域相当于备份区域

2.2 测试DNS是否开启成功

netstat -an //查看端口号是否有TCP53,UDP53

新建主机
定义一个个域名 www.baidu.com
定义其ip为1.1.1.1
在这里插入图片描述
终端测试看是否成功

nslookup www.baidu.com 

在这里插入图片描述

2.3 需要会的几条命令

ipconfig /flushdns  //之前做测试,有一些信息不对,需要清空缓存
ipconfig /displaydns //显示现在有的缓存
nslookup www.baidu.com 查看DNS服务器ip和域名解析IP

3.关于DNS的实验

3.1 设置DNS

step 1 开三台虚拟机(两台win server 带DNS服务器,一台win 7作为客户机)并且确保三台之间可以ping通

ps: ping不通的可能原因-是否在同一网段,是否关闭防火墙

在这里插入图片描述
正向查找区域-新建区域-下一步-主要区域-填写区域名称(比如qq.com)-下一步一直到完成因此10.1.1.1就是qq.com的权威服务器
在这里插入图片描述
新建主机zone,并且设IP地址6.6.6.6
在这里插入图片描述

在win 7客户机上测试DNS服务器,输入nslookup,出现DNS IP,之后输入需要解析的域名zone.qq.com,就可以了

在这里插入图片描述

ps: 公司自己搭建DNS服务器的话,域名可以只在公司的局域网有效,在互联网无效。因为DNS把域名拦截了,并且作为域名的权威解析转发给同一局域网上的其他客户机,然而一旦到局域网上,虚假的域名和ip就会露馅儿,导致无效

3.2 给服务器创建名字,解决默认服务器:unknown-反向解析

1)正向查找区域里-新建区域,起名ton.com,新建主机
在这里插入图片描述
2)新建主机-起名为dns1,地址指向自己10.1.1.1在这里插入图片描述
3)反向查找区域里-新建区域-下一步一直到IP输入10.1.1.1然后下一步一直到完成
4)在新建区域里右键点击新建PTR(指针)指向本地服务器-输入本机IP10.1.1.1,选择主机名
在这里插入图片描述
5)客户机进行测试,输入nslookup,出现服务器名称:
在这里插入图片描述

3.3 区域备份,让另一台服务器也记住这个区域

1)打win server1原始服务器,右键点击属性
在这里插入图片描述

然后允许10.1.1.2备份域名IP相关信息(qq.com和对应的IP)
在这里插入图片描述
2)打开win server 2 的DNS服务器,新建区域-选辅助区域-区域名称为qq.com-继续同步10.1.1.1相关信息-完成
在这里插入图片描述
由此,qq.com的相关信息就出现了在这里插入图片描述

3.4 设置转发器,连接两个DNS

1)win server2作为对外连接互联网的DNS服务器,新建区域(jd.com)-新建主机(IP:7.7.7.7)
在这里插入图片描述
当win7客户机想访问外部网站www.jd.com的时候,发现失败,因为局域网内的DNS1(10.1.1.1)没有www.jd.com的缓存,因此需要将DNS1与DNS2连接,访问外部网站,每当DNS1解决不了的时候,都找DNS2来解决
在这里插入图片描述
2)选择DNS1的服务器win xxxx,右键点击属性-转发器-添加10.1.1.2(也就是DNS2服务器)-确定

在这里插入图片描述

3)win 7 客户端访问www.jd.com 成功
在这里插入图片描述

3.5 起别名

1)空白处右键点击-新建别名
在这里插入图片描述

2)给zone.qq.com起别名z.qq.com
在这里插入图片描述
3)成功以后显示:
在这里插入图片描述
用客户机测试——alias是别名的意思
在这里插入图片描述

总结

1.客户机域名请求解析顺序

客户机自己的DNS缓存-----本地host文件-----找本地DNS

2.服务器对域名请求的顺序

DNS高速缓存-----本地区域解析文件-----转发器----根

3.域名解析记录类型

A-正向解析记录
CNAME-别名
PTR-反向解析记录
MX-邮件交换器
NS-域名服务器解析

4.DNS服务器分类

-主要名称服务器
-辅助名称服务器
-根名称服务器
-高速缓存服务器

5.用到的命令


```c
ipconfig       //看子网掩码,网关
ipconfig /all  //+看dns服务器
//DHCP相关命令 租约,毁约;续约
ipconfig /release 
ipconfig /renew
//DNS 查看缓存,清空缓存
ipconfig /displaydns
ipconfig /flushdns

十、WEB服务器和FTP服务器

1.WEB基础知识

1)web服务器又称网页服务器/HTTP服务器(使用HTTP协议或HTTPS)
2)HTTP协议端口号:TCP 80
HTTPS协议端口号:TCP 443
3)HTTP协议,客户端与服务器联系:
服务器发送HTTP包给客户端,客户端(淘宝网站,腾讯网站,微博网站等等)通过解析HTTP包解析语言,呈现出网页
4)web服务器软件发布:
微软:IIS(可以发布web软件和FTP站点)
linux: Apache/LAMP/Tomcat/Nginx.etc
第三方:phpstudy/XAMPP

2.配置iis部署并且搭建网站

1)遇到的问题解决

2)打开服务器管理器-点击右上方工具-IIS-选中网站右键点击-添加网站-填写相关信息
在这里插入图片描述

在这里插入图片描述
ps:D盘下新建一个文件夹专门用来配置网站相关信息

3)该服务器默认的初始网页为Default Web Site,因此打开winxp客户机登录10.1.1.1显示的是:
在这里插入图片描述
4)将自己新建的网页设置为默认网页

新建网页内容(D:/网站/TON/index.html):
在这里插入图片描述

打开服务器管理器-IIS工具-选择如图所示默认文档
在这里插入图片描述

将默认文档打开后,把刚才新建的index.html网页文件上移到的一位
在这里插入图片描述

3.默认网站的路径

在这里插入图片描述

默认网站的路径为 C:\inetpub\wwwroot

4.FTP基础知识

1)FTP全称 ——file transfor protocol 文件传输协议
2)端口号—— TCP 20/21
3)FTP工作方式
主动模式&&被动模式

十一、域

1.域的基础知识

1)英文名称 domain
2) 内网环境
-工作组:人人平等,不方便管理,默认模式
-域:人人不平等,可以进行集中管理,统一管理
3)域的特点:集中、统一管理
4)域的组成:
域控制器(域控)—— DC(Domain Controller)
成员机
5)域的部署
-安装域控制器就生成了域环境
-安装了活动目录就生成了域控制器
-活动目录AD activity directory特点:集中管理/统一管理 6)组策略GPO group policy
6)DC工作原理在这里插入图片描述

2.部署域

1)部署域方法
注意:
a.配置静态ip
b.关闭防火墙
c.DC上登录域,本地管理员自动升级为域管理员
在这里插入图片描述

d.验证AD活动目录是否安装成功

  • 查看DNS服务器上是否自动创建ton.com的区域文件
  • 自动注册DC的域名解析记录
  • 管理工具
    –AD用户和计算机
    ------computer:普通域成员机列表
    ------Domain Controller:DC列表
    ------users:域账号

2)连接域
-打开win xp
-进行桥接vmnet1
-配置静态IP
-关闭防火墙
-右键点击我的电脑-属性-计算机名-更改-隶属于域-输入域名在这里插入图片描述

在这里插入图片描述

成功!!!
在这里插入图片描述
重新启动,查看win server 2016
在这里插入图片描述
查看win xp
在这里插入图片描述

同理,win7加入域
在这里插入图片描述
然后输入管理员账号密码 ton.com\administrator+pwd,重新启动
在这里插入图片描述
在这里插入图片描述

*将计算机转移到别的目录

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

*给xp新建域用户

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
win xp登录李珊账号
在这里插入图片描述

3.常见问题

1)加入域不成功
网络是否能ping通
DNS解析是否成功
是否存在DNS缓存问题
2)域用户的权限
建议将域用户加入到本地成员机的本地管理员组中去
区分:
本地管理员组:administrator
域管理员组:Domain admin

*注意!!!!

在DC中新建用户并不能升级为域管理员!!!
在这里插入图片描述
只有在users-Domain admin才能升级为域管理员
在这里插入图片描述

4.1 OU 组织单位organization unit~有点类似于组

用于归类域资源(域用户,与计算机,域组)

新建OU
在这里插入图片描述
画圈的图标就相当于组织单位OU
在这里插入图片描述

4.2 组策略Group Policy GPO

  • 通过组策略可以修改计算机的各种属性,如开始菜单,桌面背景,网络参数等等

  • 组策略在域中,是基于OU下发的
    在这里插入图片描述

在这里插入图片描述
ps: 画框的都是响应的组策略,Default Domain Policy是响应的整个域的组织策略,修改它相当于修改整个域的组织策略

  • 新建组织策略
    在这里插入图片描述

在这里插入图片描述
新建成功
在这里插入图片描述

4.3 实验

实验1

ex1. 要求财务部门更换统一壁纸
step 1.新建财务部组策略
step 2.编辑组策略

在这里插入图片描述
在这里插入图片描述
step 3.创建共享文件夹-把墙纸放到共享文件夹
在这里插入图片描述
在这里插入图片描述
添加域用户的共享权限
在这里插入图片描述

在安全中也添加Domain Users
在这里插入图片描述
在这里插入图片描述

*组策略顺序

顺序 L.S.D.O.U
L-Local
S-站点,林
D-Domain
OU-组织单元,一系列的组织单元
当出现冲突的时候,最后的生效

正常情况下:LSDOU顺序
例1 上级OU:
桌面:aa 运行:删除
下级OU:
桌面:未配置 运行:不删除
下级用户结果
桌面:aa 运行:删除
例2
上级OU:
密码要求:3 运行:禁止 策略: a
中间OU
密码要求:4 运行:运行 策略: 未配置
下级OU
密码要求:未配置 运行:禁止 策略: 未配置
正常情况下:
密码要求:4 运行:禁止 策略: a
下级OU设置了组织继承:
密码要求:未配置 运行:禁止 策略: 未配置
上级OU设置了强制继承:
密码要求:3 运行:禁止 策略: a
上级OU设置了强制继承,下级OU设置了组织继承:
密码要求:3 运行:禁止 策略: a
中级OU设置了组织继承:
密码要求:4 运行:运行 策略: a

选择强制的时候,冲突的时候,上级OU生效,因为策略执行到上级OU 就不再向下执行了
在这里插入图片描述

下级用户设置了阻止继承
原则:组织继承跟着自己走
上级OU:
桌面:aa 运行:删除
下级OU:
桌面:未配置 运行:不删除
下级用户结果
桌面:未配置 运行:删除

实验2

给财务部门添加组策略,让他们注销的时候清理垃圾

step 1.编辑一个清理垃圾的脚本
在这里插入图片描述

用户李珊的垃圾(win xp)
在这里插入图片描述

step 2.编辑IT部门财务部门组策略
在这里插入图片描述

在这里插入图片描述

在这里插入图片描述

先将clear.bat文件粘贴到ton.com
在这里插入图片描述
在这里插入图片描述

在这里插入图片描述
成功!!!
在这里插入图片描述

实验3 用户不需要ctrl+alt+delete登录

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

其他

可以从计算机配置中改写密码的设定,增加账号安全性
在这里插入图片描述

十二、总结及实验

实验图

在这里插入图片描述

步骤

step 1.win2016,win2003, win7连同一网段vmnet1
step 2.配IP

win2016 10.1.1.1 配DC/DNS服务器
win2003 10.1.1.2 配DHCP/WEB/文件共享服务器
win7

step 3 部署DHCP

win2003
打开DHCP,右键点击授权-按下“f5/fn+f5”-图标变绿-右键点击新建作用域-填写相关信息-
在这里插入图片描述

在这里插入图片描述

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

win2003 新建共享文件夹

step 4. win2003新建共享文件夹share并把权限调为完全控制,加域用户的完全控制权限-安全里取消继承-删除其他用户并添加其他域用户
在这里插入图片描述
ps:域用户Domain Users刚开始没找到是因为对象类型没有全部勾上,把对象类型全部勾上
在这里插入图片描述
在这里插入图片描述

step 5. win2016 ton.com域中新建“mall集团 OU”下的 “IT OU”下的组,赋权限用

在这里插入图片描述
在这里插入图片描述
ps:这里组类型中的安全组和通讯组分别代表赋权限的组和发邮件的组

将用户李珊添加到IT组,右键属性-隶属于-添加-搜索it-确定
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
step6.给李珊赋予完全控制权限,IT组只有读取权限,本地管理员和域管理员完全控制权限
在这里插入图片描述
在这里插入图片描述
同理,建立IT部李玉账户users

win7连接域

在这里插入图片描述
成功!!
在这里插入图片描述

step 7.以李珊账户登录win7系统,测试共享文件
在这里插入图片描述
在这里插入图片描述
新建文件夹成功!!!!

以IT部李玉账户登录win7查看共享文件,无法对share文件夹进行删除操作,验证成功在这里插入图片描述


step 8. win2003 iis部署网站

右键点击新建-网站-弹出对话框-依次填入以下信息-在默认文档中加入新添加的html文件并且上移到第一位
在这里插入图片描述
在这里插入图片描述

在这里插入图片描述
在这里插入图片描述

在这里插入图片描述
在这里插入图片描述
win2016 DNS新建主机,配好域名和IP;win7登录网站验证
验证成功!!!

十三、渗透测试简单流程

1.基本流程

0.授权
1.信息收集
nslookup 网站名
2.扫描漏洞

  • namp=ip范围 端口 80(IIS/apache ??什么网站??)
  • 高级扫描:如IIS漏洞2003-IIS6.0 2008IIS7.0(中间件漏洞)
    网站漏洞(XSS,SQL注入等等)

3.漏洞利用
4.提权(shell环境、桌面环境、最高权限)
5.结束+留后门(木马等)
6.渗透测试报告

2.

手工测试端口号开放

telnet IP 测试端口

十三、PKI

1.基础知识

1.1、概述

1)名称
PKI-Public Key Infrastructure 公钥基础设施
2)作用
通过加密技术和数字证书保证信息的安全
3)组成
公钥加密技术,数字证书,CA ,RA

1.2、信息安全三要素

机密性,
完整性,
身份验证/操作的不可否认性。

1.3、哪些领域用到PKI
1)SSL/HTTPS
2) IPsecVPN
3) 部分远程访问VPN

1.4、公钥加密技术

作用:实现对信息加密,数字签名等安全保障

加密算法
1)对称加密算法——加解密的密钥一致
2)非对称加密算法

  • 通信双方各自产生一对公私钥
  • 通信双方各自交换公钥
  • 公钥和私钥为互相加解密关系
  • 公私钥不可互相逆推——RSA ,DH

举个例子

x+5=y(对称加密算法)
x是原文
y是密文
5是密钥、key

HASH算法:MD5 SHA(验证)
HASH算法可逆吗??不可逆!!!

非对称加密概述

详解链接
在这里插入图片描述

(1) A 要向 B 发送信息,A 和 B 都要产生一对用于加密和解密的公钥和私钥。
(2) A 的私钥保密,A 的公钥告诉 B;B的私钥保密,B 的公钥告诉 A。
(3) A 要给 B 发送信息时,A 用 B 的公钥加密信息,因为 A 知道 B 的公钥。
(4) A将这个消息发给 B (已经用 B 的公钥加密消息)。
(5) B 收到这个消息后,B 用自己的私钥解密 A的消息。其他所有收到这个报文的人都无法解密,因为只有 B 才有 B 的私钥。

1.5、数字证书

用自己的私钥摘要加密就是数字证书
摘要:HASH值
注意

  • 证书用于保证公密的合法性
  • 证书格式遵循X509标准
  • 数字证书包含信息:
    ** 使用者的公钥值
    ** 使用者表示信息(如电子邮件地址和名称)
    **有效期(证书的有效时间)
    **颁发者标识信息
    **颁发者的数字签名
  • 数字证书由权威第三发发布,即CA

在这里插入图片描述
数字证书详解

2.PKI实验

实验一、创建https网站,给网站颁发证书

step 1.搭建网站

<html>
<head>
<title>
welcome!!!!
</title>
</head>
<body>
let us go shopping!!!!
</body>

</html>

在这里插入图片描述
step 2.部署AD证书服务
继续配置CA服务
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
这里CA的公用名称指的是CA自己的名称
在这里插入图片描述
在这里插入图片描述
然后一直下一步到结束

step3. 创建证书申请

打开IIS,点击服务器证书
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
指定一个文件名,把它放到桌面上
在这里插入图片描述
虚拟机打开IE浏览器,在网址输入:
10.1.1.1/certsrv
点击申请证书
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
把证书的内容粘贴到BASE-64编码在这里插入图片描述
在这里插入图片描述
step 4.颁发证书
打开证书颁发机构-点击挂起的申请-看到刚才申请的证书点击右键颁发

在这里插入图片描述
在这里插入图片描述

点击下载证书
在这里插入图片描述
step 5.完成证书申请
在这里插入图片描述

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
点击右边的应用!!!在这里插入图片描述
成功!!
在这里插入图片描述

在这里插入图片描述

实验二、给客户机颁发证书——为了验证客户是本人!!比如平常银行用的U盾

step 0. 刚开始直接访问10.1.1.1/certsrv申请客户证书提示需要给10.1.1.1配证书变成https,所以给10.1.1.1配证书
在这里插入图片描述
在这里插入图片描述

在这里插入图片描述

DNS给ca.mall.com配ip
在这里插入图片描述
给ca.qf.com配证书
1.iis创建证书申请
2.登录ca.mall.com/certsrv/
3.申请证书
4.证书颁发机构颁发证书
5.登录ca.mall.com/certsrv/下载证书
6.iis完成证书申请
7.此时登录https://10.1.1.1/certsrv就可以申请客户机的证书了

ps:因为10.1.1.1只能分配给一个网站,暂时暂停www. mall. com
在这里插入图片描述step 1.先通过SSL设置给网站定义客户机必须有证书才能访问
在这里插入图片描述

再登录网站此时已经不能随意登录了
在这里插入图片描述
step 2. 再次登录10.1.1.1/certsrv申请证书

在这里插入图片描述

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
证书颁发机构颁发证书
在这里插入图片描述
在这里插入图片描述

在这里插入图片描述

十四、osi 7层模型-数据链路层

在这里插入图片描述
网络层; 路由器(针对IP地址的)
数据链路层:交换机

14.1 数据链路层及交换机工作原理

1.基础知识

1)数据链路层(2层,Data Link Layer)
2)传输单元:帧
3)帧结构:
帧头:6+6+2=14字节
MTU值:1500字节
帧尾:4字节
帧头内容:目标MAC、源MAC、类型
4)类型的作用:识别上层协议
0x0800:上层为IP协议
0x0806:上层为ARP协议
0x代表十六进制

在这里插入图片描述

5)工作在数据链路层的设备:交换机
6)交换机工作原理:

在这里插入图片描述

收到一个数据帧后:
1.首先学习帧中的源MAC地址来形MAC地址表
2.然后检查帧中的目标MAC地址,并匹配MAC地址表,

  • 如表中有匹配项,则单播转发 如表中没有匹配项,
  • 如表中无匹配项,则除接受端口外广播转发 MAC地址的老化时间默认是300秒

6)其他概念
交换机的端口:

E 10Mb
F 100Mb
G 1000Mb
Te 10000Mb
Console 企业级交换机有,初始管理交换机用的,用Console线连接交换机的一端,另一端连接电脑的COM口

F 0/1
0模块号
1接口号

接口速率自适应
1000/100/10M自适应:
速率模式可以为10,100,1000任何一种状态

端口状态:up/down

down的三种可能

  • 人工down掉
  • 速率不匹配
  • 双工模式不匹配

ps:
要理解全双工,就得与半双工一起比较讨论。全双工:指可以同时(瞬时)进行信号的双向传输(A→B且B→A)。指A→B的同时B→A,是瞬时同步的。半双工:指一个时间内只有一个方向的信号传输(A→B或B→A)

直通线和交叉线的区别

  • 直通线用来连接电脑和交换机(或HUB),路由器和交换机(或HUB)
  • 交叉线用来连接电脑和电脑,路由器和路由器。

14.2. 交换机基本工作模式及命令

1.基本工作模式

1)用户模式:
switch>可以查看交换机的基本简单信息,且不能做任何修改配置,打开PT软件,点击交换机,出现交换机命令行
在这里插入图片描述
2)特权模式

switch>enable
switch>e
switch#

可以查看所有配置,且不能修改配置,但可以做测试、保存、初始化等操作

3)全局配置模式-默认不能查看配置,可以修改配置且全局生效!

输入

configure terminal  #进入全局配置模式

在这里插入图片描述
4)接口配置模式-默认不能查看配置,可以修改配置且对该端口生效!

输入

interface f0/1

在这里插入图片描述
5)console口/线/控制台配置模式-默认不能查看配置,可以修改配置且对该console口生效!

输入

line console 0 # 进入console口模式

在这里插入图片描述
6) 注意

  • exit 退出上一级
  • end 直接退到特权模式
  • 支持命令缩写
  • 历史命令
  • tab补全命令

2.交换机基本命令

2.1 修改交换机名

conf t #先进入全局修改命令
hostname xx(新交换机名) #修改交换机名

在这里插入图片描述
2.2 设置用户密码

line co 0
password 密码
login
exit

在这里插入图片描述
在这里插入图片描述
2.3 交换机开机
a.
在内存中存在一个文件: running-config

第一次开机,系统会在内存中自动创建一个新的干净的running-config,关机以后就没有了

b.特权模式保存配置文件

copy running-config startup-config / write memory
#保存交换机的配置:把running-config的内容复制到startup-config

保存交换机的配置:把running-config的内容复制到startup-config

c.交换机开机动作

  • 先去硬盘中查找startup-config是否存在
  • 如果不存在,在内存中创建新的running-config
  • 如果存在,则复制startup-config到内存中并改名running-config

d.产看running-config配置

en
show running-config

2.4 重启

en
reload

2.5 设置特权模式下的密码

conf t
enable password 密码
end
# 查看是否配置成功
show running-config / show run缩写

在这里插入图片描述
但是密码不安全,因为输入
show run
就可以看到密码!!!

因此,可以引用另一个命令

enable secret 654321

用show run会以密文形式显示
在这里插入图片描述
2.6 清除startup-config表

erase startup-config

在这里插入图片描述

2.7 查看MAC地址表

show mac-address-table

给交换机来凝结两个PC端,并且查看MAC地址表
在这里插入图片描述
在这里插入图片描述
2.8 查看接口简要信息

show ip interface brief/ show ip int b

在这里插入图片描述
人为把接口down掉

en
conf t
int f0/6
shutdown # 把f0/6的接口down掉

在这里插入图片描述
结果显示:
在这里插入图片描述
人为把接口开启

en
conf t
int f0/6
no shutdown

在这里插入图片描述
结果
在这里插入图片描述
2.9 特权命令在其他模式也可以使用的方式

命令前加do
比如:

do show run
do  show ip int b

在这里插入图片描述
2.10 删除配置

  • 在哪配置的,就在哪删
  • 命令前加no空格
  • 原命令中有参数,并且参数具有唯一性,则删除时不需要加参数,如:
conf t
hostname sw1
# 删除配置
conf t
no hostname`

14.3 路由器配置

1.为三层端口配ip

在这里插入图片描述

如图所示,交换机出厂的时候默认端口就是打开的,而路由器出场的时候端口默认是down的,所以刚开始虽然交换机和两个PC之间互相能够ping通,但是与路由器之间没有连接成功

我们需要先给路由器配IP,并且打开路由器端口(no shut)
命令如下:

en
conf t
do show ip int b #先查询都有哪些端口
int g 0/0
ip add 10.1.1.254 255.255.255.0 # 给路由器配网关
no shut 

在这里插入图片描述
2.路由器连接Telnet协议进行远程控制

a.首先查看可以远程控制路由器的终端个数

en
conf t
line vty 0 ?

line vty 0 4,该命令是允许用户远程登陆,即不用用户插Console线缆,只要设备连接网络,配置了接口IP地址即可远程使用Telnet、或者ssh的方式登陆到设备上

在这里插入图片描述
b.给Telnet协议设置密码

在这里插入图片描述
现在就可以实现通过Telnet远程控制路由器了
在这里插入图片描述
但是路由器本身没有设置特权密码,在给路由器设置一个特权密码,然后通过10.1.1.1的电脑终端进行控制
在这里插入图片描述
控制成功
在这里插入图片描述
c.ssh加密连接路由器

刚开始,在路由器终端输入

transport input ? # 查看相关命令
transport input ssh
ip domain-name r1.qf.com # 设置域名
crypto key generate rsa

在这里插入图片描述
在这里插入图片描述
此时,电脑终端通过Telnet连接就不成功了
在这里插入图片描述

电脑终端通过ssh加密连接

ssh -l r1 10.1.1.254/ ssh r1@10.1.1.254

在这里插入图片描述
如果想通过telnet连接,就通过路由器终端:

transport input all

在这里插入图片描述
再连接就成功了
在这里插入图片描述
给用户配置账号密码,使用户无论通过ssh连接还是telnet连接,都能使用账号密码登录

conf t
hostname r1
ip domain-name r1.qf.com
crypto key generate rsa  # 生成密钥对
line vty 0 4
transport input telnet/ssh/all/none
login local
exit
username 账号 password 密码

在这里插入图片描述

在这里插入图片描述

**实验

记住:无论连多少台交换机,他们都在同一个网段,影响网段的只能是路由器,路由器有多少个接口,那么局域网就有多少个网段

实验案例图:

在这里插入图片描述
1.打开路由器接口,使路由器与左边和右边交换机相连接
在这里插入图片描述
在这里插入图片描述
此时,两边的网段仍然不能ping通,因为没指网关,此时给电脑配置网关10.1.1.254和20.1.1.254
在这里插入图片描述
在这里插入图片描述
此时可以ping通
在这里插入图片描述
2.远程连接路由器,10.1.1.1控制路由器
在这里插入图片描述
在这里插入图片描述
3. 为交换机配置管理IP,便于远程管理

通常情况下,二层交换机不能配IP,所以无法被telnet远程管理,所以一般二层交换机通常都有虚拟主机,便于配ip用于远程管理,因为

conf t
int vlan 1
ip add 10.1.1.253 255.255.255.0
no shut

在这里插入图片描述
检查状态的时候可以发现多出了一个vlan1
在这里插入图片描述
测试是否连接成功,登录10.1.1.1的终端发现可以ping通
在这里插入图片描述
为交换机配置telnet远程管理的用户名和密码
在这里插入图片描述
在这里插入图片描述
4.为交换机配置默认网关,可被跨网段管理

conf t
ip default-gateway 10.1.1.254

给交换机20.1.1.253配置默认网关
在这里插入图片描述
10.1.1.1 ping 20.1.1.253,说明现在交换机可以跨网段联通了
在这里插入图片描述
远程管理成功
在这里插入图片描述
由此,10.1.1.1可以远程管理路由器10.1.1.254,交换机1 10.1.1.253,交换机2 20.1.1.253
在这里插入图片描述
5. 关闭自动解析功能:

conf t
no ip domain-lookup

十五、osi 7层模型-网络层(三层及以上的设备可以配IP,路由器有IP,MAC,交换机没IP)

15.1 IP包头分析

  • 1Byte(字节)=8bit(比特)
  • IP包头长度可变20字节-60字节

在这里插入图片描述
总长度的理解:
在这里插入图片描述

分片的原理:
在这里插入图片描述

15.2 路由原理

1.路由概述

跨越从源主机目标主机的一个互联网络来转发数据包的过程,路由器为IP包选择路径的过程
路由器为数据包选择路径的唯一依据是路由表

在这里插入图片描述

2.路由工作在网络层

  • 根据“路由表”转发数据
  • 路由选择
  • 路由转发

3.交换机工作在数据链路层

  • 根据“MAC地址表”转发数据
  • 硬件转发

4.静态路由有默认路由的配置

  • 静态路由
conf t
ip route 目标网段 子网掩码 下一跳IP
  • 默认路由
conf t
ip route 0.0.0.0  0.0.0.0  address

比如:

ip route 10.1.1.0  255.255.255.0  20.1.1.2

浮动路由:
相同的目的地址,不同的下一跳地址,另一条下一跳的优先级低

在静态或默认路由后加空格+数字(正整数)

15.3 实验一

在这里插入图片描述
第一步,把电脑和路由器联通,

1.配电脑IP
在这里插入图片描述
2.把路由器接口打开

en
conf t
int g0/0
ip add 10.1.1.2 255.25.255.0
no shut
exit
int g0/1
ip add 20.1.1.1 255.255.255.0
no shut
exit

以此类推

3.查看路由表

do show ip route

在这里插入图片描述
路由优化

R1-左一路由器

在这里插入图片描述
R2-中间路由器
在这里插入图片描述
R3-右一路由器

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

15.4 实验二

在这里插入图片描述
第一步,使两个路由器和两个路由器之间能够互相联通

第二步,设置路由优化

r1路由器
在这里插入图片描述
r2路由器
在这里插入图片描述

结果
在这里插入图片描述

15.5 ARP协议-只在内网范围,内网攻击渗透,因为路由器不转发IP包

1.广播的基础知识

a. 广播与广播域

  • 广播:将广播地址作为目的地址的数据帧
  • 广播域:网络中能接收到同一个广播所有节点的集合

b.MAC地址广播

广播地址为FF-FF-FF-FF-FF-FF

c.IP地址广播

  • 地址为255.255.255.255
  • 广播IP地址为IP地址网段的广播地址,如192.168.1.255/24

2.什么是ARP协议

  • ARP协议为地址解析协议,Address Resolution Protocol
  • 将一个已知的IP地址解析成MAC地址,也就是说ARP告诉我们如何知道目的MAC地址

ARP协议过程

1)PC1发送数据给PC2,查看缓存有没有PC2的MAC地址
在这里插入图片描述
2)PC1发送ARP请求消息(广播),请求解析目的MAC地址
在这里插入图片描述
3) 所有主机收到ARP请求消息

  • PC2回复ARP应答(单播
  • 其他主机丢弃请求包

在这里插入图片描述
4)PC1将PC2的MAC地址计入缓存,发送数据
在这里插入图片描述

**ARP命令

arp -a # 查看ARP缓存表
arp -d # 清楚除RP缓存
arp -s # ARP绑定

3.ARP攻击

ARP攻击主要是存在于局域网网络中,局域网中若有一台计算机感染ARP木马,则感染该ARP木马的系统将会试图通过“ARP欺骗”手段(发送伪造虚假的ARP报文,广播或单播,)截获所在网络内其它计算机的通信信息,并因此造成网内其它计算机的通信故障。

  • 如果虚假保温的MAC是伪造的,不存在的,实现ARP攻击及如果为中断通信/断网
  • 如果虚假报文的mac使攻击者自身的mac地址,实现ARP七篇,结果可以监听、盗取、篡改、控制流量,但不中断通信

缺陷:ARP协议没有身份验证机制

15.6 路由原理(交换机既不能配IP也没有MAC地址)

在这里插入图片描述
1)一个帧到达路由,路由器首先检查目标MAC地址是否自己,如果不是则丢弃它,如果是则解封装,并将IP包送到路由器内部

2)路由器检查IP包头的目标IP,并匹配路由表,如果匹配失败,则丢弃,并向源IP回馈错误信息,如果匹配成功,则将IP包路由到出接口

3)封装帧,首先将出接口的MAC地址作为源MAC封装好,然后检查ARP缓存表,检查是否有下一跳的MAC地址,如有,将提取并作为目标MAC地址封装到帧中,如没有,则发送ARP广播请求下一跳的MAC,并获取对方的MAC地址,再记录缓存,并封装帧,最后将帧发送出去

15.7 实验

*** ARP攻击,是网络瘫痪-网络执法官

***ARP欺骗,使网络中产生中间人盗取用户信息——用到的软件cain.exe

1.搭建几台虚拟机,设置在同一网段,使得相互之间可以ping通

2.在win2016下载cain.exe,图标如下并且打开
在这里插入图片描述

3.点击左上角第二个图标,开始抓取数据
在这里插入图片描述
4.右键点击Scan MAC Address,扫描MAC地址,一共找到三台IP
在这里插入图片描述

5.点击右下角的APR,然后点击上方的加号选择攻击对象在这里插入图片描述
6.选择10.1.1.1和10.1.1.4进行攻击在这里插入图片描述
效果如下:
在这里插入图片描述
选中上方黄色投毒按钮
在这里插入图片描述
投毒开始,此时win2016可以监听10.1.1.1和10.1.1.4之间的对话
在这里插入图片描述
7. 10.1.1.1进行测试

可以看出来10.1.1.1依然可以和10.1.1.4进行通信,只不过10.1.1.3和10.1.1.4的MAC地址变成了一样的,说明10.1.1.3正在伪装成10.1.1.4进行与10.1.1.1的对话
在这里插入图片描述
8.当10.1.1.1试图telnet10.1.1.4的时候,10.1.1.3可以监听到密码

10.1.1.1电脑操作如下

telnet 10.1.1.4
y
Administrator
密码

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
打开投毒软件,右键点击view可以看到用户名和密码

在这里插入图片描述
在这里插入图片描述

15.8 ARP防御

1.静态ARP绑定

手工绑定/双向绑定

路由器和用户之间互相绑定各自的MAC地址,使得中间人无法欺骗路由器和用户(因为欺骗的时候,用户和路由器的MAC地址会变成中间人的MAC地址

缺点:因为在路由器中,属于缓存,一关机,缓存就没了。而且一条一条配,工作量太大。

但是可以把服务器和路由器进行双向绑定,这样当员工遭受攻击的时候,服务器还可以正常运转

操作命令

arp -s 10.1.1.254 00-01-2c-a0-e1-09 # 网关IP和MAC地址
arp -a  # 查看ARP缓存表

2、ARP防火墙

arp防火墙会不断的跟网关发送报文,证明自己是用户,和ARP攻击的原理一样,造成网关的奔溃

3.硬件级防御-网课day14-04

交换机支持端口做动态ARP绑定(配合DHCP服务器)
或作静态绑定

conf t
ip dhcp snooping  # 开启DHCP监听功能查看是否支持动态绑定
int range f0/1-48

15.9 ICMP协议

1.ICMP端口号?没有端口号
2.ICMP协议是干什么的?

网络探测与回馈机制

  • 网络探测
  • 路由跟踪
命令:
 windows:tracert IP地址 
 linux或路由器:traceroute IP地址
  • 错误反馈

3.ICMP协议的封装格式:

ICMP头 数据

ICMP头:ICMP类型字段,代码

ICMP类型字段:

8:ping请求
0:ping应答
3:目标主机不可达
11:TTL超时

在这里插入图片描述

十六、VLAN(Virtual LAN虚拟局域网)——二层技术,工作于交换机

16.1基础知识

  1. 广播/广播域
  2. 如何控制广播?
    控制广播=隔离广播域
    路由器隔离广播(物理隔离)
    路由器隔离广播缺点:成本高,不灵活
    在这里插入图片描述
    在这里插入图片描述
    发起广播的几种形式总结
  • DHCP分IP的时候,PC会发起广播请求IP地址
  • 封装数据帧的时候,PC需要MAC地址,会发送arp请求获取MAC地址,进行广播
  • PC只要把广播的目标MAC地址改为12个F就可以进行广播

3.广播的危害:
增加网络/终端负担,传播病毒,安全性

4.采用新的技术VLAN来控制广播

VLAN技术是在交换机上实现的且是通过逻辑隔离划分的广播域

不同的VLAN无法通信,不同的VLAN ID也无法互相通信,通过交换机实现

5.VLAN是干什么的?

控制广播,逻辑隔离广播域
一个VLAN=一个广播域=一个网段

6.VLAN的类型

静态VLAN:

  • 手工配置
  • 基于端口划分的VLAN

在这里插入图片描述
动态VLAN

  • 手工配置
  • 基于MAC地址划分的VLAN
  • 采用802.1x端口认证-基于账号来划分vlan

7.静态VLAN命令:

在这里插入图片描述

1)创建VLAN

conf t 
vlan ID,ID,ID-ID
[name 自定义名称]
exit

在这里插入图片描述
2)查看VLAN表

show vlan brief/show vlan b

在这里插入图片描述
3)将端口加入到VLAN:

int f0/x
switchport access # 把该交换机端口加入到vlan

在这里插入图片描述
结果已经ping不通了
在这里插入图片描述
在这里插入图片描述

加个电脑,把10.1.1.3和10.1.1.1配在同一vlan,之后他们可以互相通信
在这里插入图片描述

在这里插入图片描述

注意:

交换机收到数据帧之后,先看MAC表,看是否属于本网段,如果属于本网段就转到交换机内部,这个时候再看VLAN表

再加一个交换机和两台PC

在这里插入图片描述

发现虽然10.1.1.4接入vlan10,但是无法ping通10.1.1.1和10.1.1.3,原因是两个交换机sw1端口f0/1和sw2端口f0/3之间默认联通的是vlan1,所以vlan10不起作用,等都调到vlan10就可以相互ping通

16.2 Trunk 中继链路/公共链路

1.trunk

作用:允许所有VLAN数据通过Trunk链路,一般适用于交换机与交换机之间
方法:通过在数据帧上加标签,来区分不同的vlan数据

2.trunk标签:
1)ISL标签;cisco私有的,标签大小30字节26+4
2)802.1q标签:公有协议,所有厂家都支持,标签大小4字节,属于内部标签

3.交换机端口链路类型:

1)接入端口:也称为acces端口,一般用于连接pc,只能属于某一个vlan,也只能传输一个vlan数据

2)中继端口:也称为trunk端口,一般用于连接其他交换机,属于公共端口,允许所有vlan数据通过

4.配置trunk命令:

int f0/x
[switchport trunk encapsulation dotlq/isl] #给交换机加标签
[switchport mode trunk/access] #选择trunk模式或者access模式
exit

trunk实验图:
在这里插入图片描述

给交换机sw1的f0/4配trunk链路
在这里插入图片描述
给交换机sw2的f0/3配置trunk链路
在这里插入图片描述
10.1.1.1,10.1.1.3和10.1.1.4之间能够相互ping通

16.3 交换机环形广播风暴

如果二层交换机产生物理环路,会一直产生ARP广播不断循环,TTL属于三层设备路由器,因此不生效

在这里插入图片描述

十七、单臂路由和三层交换机

1.VLAN控制广播域
2.不同的vlan间无法通信
3.1个vlan=1个网段
如:
vlan10——IT——10.1.1.0/24
vlan20——cw——20.1.1.0/24

4.不同的vlan之间也能通信,具体流程看P73单臂路由

不同vlan键通信是靠路由实现通信的,通常是单臂路由
在这里插入图片描述

在这里插入图片描述

小实验1

实验图
在这里插入图片描述

配置交换机sw1
在这里插入图片描述
配置路由器r1
在这里插入图片描述
如上图显示仍然没有连接成功,因为没有打开源端口
在这里插入图片描述
结果成功
在这里插入图片描述

5.1 在三层路由器上部署DHCP服务器

在这里插入图片描述

conf t
ip dhcp excluded-address 10.1.1.1 10.1.1.99
ip dhcp pool v10
network 10.1.1.0 255.255.255.0
default-router 10.1.1.254 #指定网关
dns-server 40.1.1.1 
exit

最后实现自动分配的地址值为10.1.1.100
在这里插入图片描述
验证成功
在这里插入图片描述

5.2 在服务器上部署DHCP服务器

在这里插入图片描述
a.配置设备做到全网互通——见千峰网课P72
b.点开40.0服务器,配置IP和默认网关等等
在这里插入图片描述
c.创建DHCP服务器,点击上方service,然后选择DHCP,填写作用域相关信息
在这里插入图片描述
d.虽然已经搭建好了,但是服务器属于vlan40,广播传达不到其他信道,因此各个vlan需要向路由器请求帮助,要求与vlan 40的服务器进行通信,这个时候路由器会偷偷帮助各个vlan单播与vlan40服务器的通信,这个过程叫做DHCP中继

conf t
int g0/0.1
ip helper-address 40.1.1.1
exit

在这里插入图片描述

6.单臂路由缺点:

a.出现网络瓶颈
b.容易发生单点物理故障(所有的子接口依赖于总物理接口)
c.VLAN间通信每一个数据帧都进行单独路由

7.三层交换技术

  • 三层交换机=三层路由+二层交换机

  • 三层路由引擎是可以关闭或开启的

conf t
ip routing # 开启三层路由功能
no ip routing # 关闭三层路由功能
  • 三层交换机的优点(与单臂路由相比):
    -解决了网络瓶颈问题
    -解决了单点故障(虚拟接口不在依赖于任何的物理接口)
    -因此路由,永久交换

  • 原理:
    在这里插入图片描述
    一般公司架构

在这里插入图片描述

  • 在三层交换机上起虚接口(配置vlan的网关)
int vlan 10 
ip add 10.1.1.254 255.255.255.0
no shut
exit
  • 二层端口升级为三层端口
    int f0/x
    no switchport
    ip add …
    no shut

8. HSRP协议——热备份路由协议

1.HSRP组号:1-255
没有大小之分
2.虚拟路由器的IP成为
虚拟IP地址
3.HSRP组的成员
虚拟路由器(老大)
活跃路由器 Active
备份路由器 standby
4.HSRP优先级:1-255
默认为100
5.HSRP组成员通过定时发送
hello包来交流,默认每隔3秒
hello时间3秒,坚持时间10秒
6.占先权 preempt
作用:当检测不到对方,或检测到对方优先级比自己低,立即抢占活跃路由的名分

7.配置跟踪track,跟踪外网端口状态,当外哇嘎端口down掉,则自降优先级

8.命令窗口

# 配置活跃路由器R1
int f0/0
# 配置组号
standby 1 ip 192.168.1.254
# 配置优先级
standby 1 piority 200
# 配置占先权
standby 1 preempt 
# 配置监听端口,当f0/0坏掉的时候,自降优先级
standby 1 track f0/1

# 配置备份路由器R2
int f0/0
# 配置组号
standby 1 ip 192.168.1.254
# 配置优先级
standby 1 piority 190
# 配置占先权
standby 1 preempt 

# 查看HSRP状态
show standb br

9.实验
在这里插入图片描述

  • 0
    点赞
  • 0
    评论
  • 3
    收藏
  • 扫一扫,分享海报

©️2022 CSDN 皮肤主题:游动-白 设计师:我叫白小胖 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值