【POJ 2352】Stars

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39786 Accepted: 17265

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.




题目大意:平面内有n个星星,定义对于第i个星星,在它左下方的星星的数目为它的level(包含边界),求每个星星的Level。
思路:简单的树状数组,用一个sum数组储存每一个星星的level,每次输入的时候进行更新。


代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#define N 32010
using namespace std;
int sum[N+1];
int lowbit(int k)
{
    return k&(-k);
}
void add(int i,int x)
{
    while(i<=N)
    {
        sum[i]+=x;
        i+=lowbit(i);
    }
}
int getSum(int i)
{
    int res=0;
    while(i>0)
    {
        res+=sum[i];
        i-=lowbit(i);
    }
    return res;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int a[15010];                   ///a数组保存对sum求和后的值,也就是第i个星星的level
        memset(sum,0,sizeof(sum));
        memset(a,0,sizeof(a));
        for(int j=0;j<n;j++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            a[getSum(x+1)]++;
            add((x+1),1);
        }
        for(int j=0;j<n;j++)
        {
            printf("%d\n",a[j]);
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值