hdu 2602 Bone Collector(dp46)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 53210    Accepted Submission(s): 22383


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
题目大意:有一个收集骨头的人,有一个V容量的包裹,他想要尽可能收集总价值最大的骨头,问你最多能收藏价值多少的骨头。
题目分析:这是一个比较典型的01背包问题,需要注意的是数要用long long型。然后,,,好像就没有然后了。贴代码,哦对了,那个状态转移方程是dp【j】=max{dp【j-a【i】】+b【i】,dp【j】};嗯,就是这样。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
#define maxn 1005
long long  dp[maxn],a[maxn],b[maxn];
int main(){
	int n,m,t;
	while(~(scanf("%d",&t))){
		while(t--){
			memset(dp,0,sizeof(dp));
		scanf("%d%d",&n,&m);
		for(int i=0;i<n;i++)
		   scanf("%I64d",&b[i]);
		for(int i=0;i<n;i++)
		   scanf("%I64d",&a[i]);
		for(int i=0;i<n;i++)
		   for(int j=m;j>=a[i];j--){
		   	dp[j]=max(dp[j-a[i]]+b[i],dp[j]);
		   }
		printf("%lld\n",dp[m]);
		}
	}
	return 0;
}



 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值