poj1026

 

如题:http://poj.org/problem?id=1026

 

Cipher
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19949 Accepted: 5354

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

Source

 

 

 

思路:有n个位置,编号为[1,n]。key[]记录了这n位上的输入的数字。如果题目给出的input中的n个数没有重复,则在第i个位置上的数,不停的i=key[i],一定可以在n次内回到i位置。因此求出n个位置上每一位的“周期”,最终i位置字符跳的次数就是cnt=k%time[i]  .k是给出的变换次数.

注意输出!

wa了一晚上 发现每一组后面输出一个空行,是每一组..并不是每一个答案后输出一个空行。

#include<iostream>
#include<cstring>
#include<cstring>
using namespace std;
 

int n,k;
int key[250];
char code[250];
int time[250]; //time[i]:code[i]的字符循环多少次后能回到原来位置
char res[250];

void ini_time()
{
 int i;
 for(i=1;i<=n;i++)
 {
  int now_pos=key[i];
  int cnt=1;
  while(now_pos!=i)
  {
   now_pos=key[now_pos];
   cnt++;
  }
  time[i]=cnt;
 }
}
int FindPos(int p) //为code[i]字符寻找k次后的新位置
{
 int i;
  int cnt=k%time[p]; //实际要移动的次数
  for(i=0;i<cnt;i++)
   p=key[p];
 return p;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
// freopen("C:\\2.txt","w",stdout);
 while(~scanf("%d",&n))
 {
  if(!n)
    break;
  int i;
  for(i=1;i<=n;i++)
   scanf("%d",&key[i]);
  while(1)
  {
   scanf("%d",&k);
   if(!k)
    break;
   getchar();
   gets(code+1);
   ini_time();
   for(i=strlen(code+1)+1;i<=n;i++)
    code[i]=' ';
   for(i=1;i<=n;i++) //找k次后的位置
   {
    int pos=FindPos(i);
    res[pos]=code[i];
   }
  res[n+1]='\0';
   printf("%s\n",res+1);
  }
  printf("\n");
 }
 return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值