CodeForces 620 B. Grandfather Dovlet’s calculator(水~)

Description
在电子表上每个数字的显示情况如下图,先给出两个整数a和b,问表示出区间[a,b]中所有数需要多少个黑段
这里写图片描述
Input
两个整数a和b(1<=a<=b<=10^6)
Output
输出电子表表示出区间[a,b]中所有数字需要多少黑段
Sample Input
1 3
Sample Output
12
Solution
水题
Code

#include<cstdio>
#include<iostream>
using namespace std;
int table[]={6,2,5,5,4,5,6,3,7,6};
int a,b;
int count(int x)
{
    int ans=0;
    while(x)
    {
        ans+=table[x%10];
        x/=10;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&a,&b))
    {
        int ans=0;
        for(int i=a;i<=b;i++)
            ans+=count(i);
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值