CodeForces 765 A.Neverending competitions(水~)

Description

一个人有很多会要开,每次开会他会从家去开会地点,开完会再回家,他可能在一个地方开会多次,刚开始他在家,给出 n n 个连续的行程,但是是乱序的,判断这个人现在在家还是在开会

Input

第一行一整数n表示行程数,之后输入这个人家的名称以及这 n n 个行程(1n100)

Output

输出这个人现在是在家还是在开会

Sample Input

4
SVO
SVO->CDG
LHR->SVO
SVO->LHR
CDG->SVO

Sample Output

home

Solution

开一次会如果回家则会有来回两个行程,故如果 n n <script type="math/tex" id="MathJax-Element-5">n</script>为奇数则该人在家,否则在开会

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 111
int n;
string a; 
int main()
{
    while(~scanf("%d",&n))
    {
        cin>>a;
        for(int i=1;i<=n;i++)cin>>a;
        printf("%s\n",n&1?"contest":"home");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值