pyspark缺少zlib依赖解决方法(python3.6.5,zlib1.2.11)

因为缺少zlib,需要先去下安装载这个包,我的版本是1.2.11,地址为http://www.zlib.net/zlib-1.2.11.tar.gz

安装zlib:

tar xzvf zlib-1.2.11.tar.gz
cd zlib-1.2.11
./configure
sudo make
sudo make install
./configure --prefix=/usr/local/python3.6.5 
sudo make
sudo make install

就可以了

之前搭pyspark环境,准备用python3,结果被这个问题困扰好久,也尝试很多文章的做法,说需要在python编译时在最后显式指向zlib库,然后尝试都不行

最后发现最新版的python编译时不需要显式的指向,反而没有效果,编译安装了zlib之后再编译Python就可以了



阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页