hdu 5805 NanoApe Loves Sequence

21 篇文章 0 订阅
3 篇文章 0 订阅

题目链接:hdu 5805

NanoApe Loves Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)

Problem Description
NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F.

Now he wants to know the expected value of F, if he deleted each number with equal probability.

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains an integer n, denoting the length of the original sequence.

The second line of the input contains n integers A1,A2,…,An, denoting the elements of the sequence.

1≤T≤10, 3≤n≤100000, 1≤Ai≤109

Output
For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by n.

Sample Input
1
4
1 2 3 4

Sample Output
6

比赛的时候想到的是记录前三大的值,还要分别考虑这三个值和去掉的数原本的左右差值和去掉之后的差值的大小关系,实现起来容易有坑,WA的一声就哭了……

f1正序记录前i个数中差值的绝对值的最大值,f2倒序记录i后面的数中差值的绝对值的最大值。最后再从f1[i - 1]、f[i + 1]和abs(arr[i - 1] - arr[i + 1])中取最大值。

最后要加上去掉arr[0]和arr[n - 1]的情况。

PS:没有试验是否会爆int,直接写的long long.

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define MAX 100005
#define mod 1000000007
#define INF -0x3f3f3f3f

using namespace std;

long long int arr[MAX];
long long int f1[MAX], f2[MAX];

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)  
            scanf("%I64d", &arr[i]);

        long long int ans = 0;
        memset(f1, 0, sizeof(f1));
        memset(f2, 0, sizeof(f2));
        for(int i = 1; i < n; i++)  
            f1[i] = max(f1[i - 1], abs(arr[i] - arr[i - 1]));
        for(int i = n - 2; i >= 0; i--) 
            f2[i] = max(f2[i + 1], abs(arr[i] - arr[i + 1]));

        for(int i = 1; i < n - 1; i++)  
            ans += max(max(f1[i - 1], f2[i + 1]), abs(arr[i - 1] - arr[i + 1]));
        ans += f1[n - 2];
        ans += f2[1];
        printf("%I64d\n", ans);
    }
    return 0;
}

运行结果:
这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值