hdu 5813 Elegant Construction (贪心)

21 篇文章 0 订阅
2 篇文章 0 订阅

题目链接:hdu 5813

Elegant Construction

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Special Judge

Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it’s your showtime!

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.

Output
For each test case, output “Case #X: Y” in a line (without quotes), where X is the case number starting from 1, and Y is “Yes” if you can construct successfully or “No” if it’s impossible to reach the requirements.

If Y is “Yes”, output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.

Sample Input
3
3
2 1 0
2
1 1
4
3 1 1 0

Sample Output
Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4

排一遍序,从需要连的点最多的那个点开始连。

连线要倒序连,这样就不会被后面的点连的边影响到,因为后面的点连的肯定都是前面的点连过的点。

虽然写完觉得挺水的,但是回想起我这么个题也想了一会……

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#include <algorithm>
#define MAX 1005
#define mod 1000000007
#define INF -0x3f3f3f3f

using namespace std;

struct node
{
    int cnt, id;

    bool friend operator < (const node &a, const node &b)
    {
        return a.cnt > b.cnt;
    }
}arr[MAX];

int main()
{
    int T;
    scanf("%d", &T);
    for(int k = 1; k <= T; k++)
    {
        int N, total = 0, flag = true;
        scanf("%d", &N);
        for(int i = 1; i <= N; i++)
        {
            scanf("%d", &arr[i].cnt);
            arr[i].id = i;
            total += arr[i].cnt;
        }
        sort(arr + 1, arr + N + 1);

        printf("Case #%d: ", k);
        for(int i = 1; i <= N; i++)
        {
            if(arr[i].cnt > N - i)
            {
                printf("No\n");
                flag = false;
                break;
            }
        }
        if(!flag)
            continue;
        else
            printf("Yes\n%d\n", total);
        for(int i = 1; i <= N; i++)
        {
            for(int j = N, cou = 0; j > i && cou < arr[i].cnt; j--, cou++)
            {
                printf("%d %d\n", arr[i].id, arr[j].id);
            }
        }
    }
    return 0;
}

运行结果:
这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值