poj 2570 Fiber Network(传递闭包,floyd+位运算)

Fiber Network
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2703 Accepted: 1242

Description

Several startup companies have decided to build a better Internet, called the "FiberNet". They have already installed many nodes that act as routers all around the world. Unfortunately, they started to quarrel about the connecting lines, and ended up with every company laying its own set of cables between some of the nodes.
Now, service providers, who want to send data from node A to node B are curious, which company is able to provide the necessary connections. Help the providers by answering their queries.

Input

The input contains several test cases. Each test case starts with the number of nodes of the network n. Input is terminated by n=0. Otherwise, 1<=n<=200. Nodes have the numbers 1, ..., n. Then follows a list of connections. Every connection starts with two numbers A, B. The list of connections is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the unidirectional connection, respectively. For every connection, the two nodes are followed by the companies that have a connection from node A to node B. A company is identified by a lower-case letter. The set of companies having a connection is just a word composed of lower-case letters.
After the list of connections, each test case is completed by a list of queries. Each query consists of two numbers A, B. The list (and with it the test case) is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the query. You may assume that no connection and no query contains identical start and end nodes.

Output

For each query in every test case generate a line containing the identifiers of all the companies, that can route data packages on their own connections from the start node to the end node of the query. If there are no companies, output "-" instead. Output a blank line after each test case.

Sample Input

3
1 2 abc
2 3 ad
1 3 b
3 1 de
0 0
1 3
2 1
3 2
0 0
2
1 2 z
0 0
1 2
2 1
0 0
0

Sample Output

ab
d
-

z
-
题意:给出n个结点,给出若干条连接结点的路径,路径是单向的,路径上有小写字母。例如:当结点1和结点2之间的路径有a、b,结点2和结点3之间的路径有b、c,那么结点1和结点3之间的路径就会出现b(即使结点1和结点3之间没有直接相连的路径或路径上没有b)。每次询问结点a和b之间的路径有哪个小写字母。
思路:传递闭包,用floyd。若n^3的floyd再加上查找相同字母,则显然TLE。有什么方法不用查找相同的字母?用位运算!G[a][b]保存a与b路径上的小写字母的集合,通过并(|)运算即可合并结合
 
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;

int main()
{
    int n;
    int a,b;
    int G[205][205];
    char com[30];
    while(cin>>n,n)
    {
        memset(G,0,sizeof(G));
        while(cin>>a>>b)
        {
            if(!a&&!b) break;
            cin>>com;
            int i=0;
            while(com[i])
            G[a][b]|=1<<(com[i++]-'a');
        }
        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
                for(int j=1; j<=n; j++)
                    if(G[i][k]&G[k][j])
                    G[i][j]|=G[i][k]&G[k][j];

        while(cin>>a>>b)
        {
            if(!a&&!b) break;
            if(G[a][b]!=0)
            {
                int i=0,temp=G[a][b];
                while(temp)
                {
                    if(temp&1)
                    putchar(i+'a');
                    temp>>=1;
                    i++;
                }
            }
            else
            putchar('-');
            putchar('\n');
        }
        putchar('\n');
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值