【POJ 1716 Integer Intervals】+ 差分约束

Integer Intervals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14475 Accepted: 6149
Description

An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b.
Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.
Input

The first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.
Output

Output the minimal number of elements in a set containing at least two different integers from each interval.
Sample Input

4
3 6
2 4
0 2
4 7
Sample Output

4

限制条件有三个:

1、对于区间,必定有num[start] <= num[end]-2;

2、对于整数点,必有num[i] <= num[i+1];

3、对于整数点,必有num[i+1] <= num[i]+1;

AC代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int K = 1e4 + 10;
int a[K],b[K],num[K];
int main()
{
    int N;
    while(scanf("%d",&N) != EOF){
        int l = K,r = 0;
        for(int i = 1; i <= N; i++)
            scanf("%d %d",&a[i],&b[i]), b[i]++,l = min(l,a[i]),r = max(r,b[i]);
        int ok = 1;
        while(ok){
          ok = 0;
          for(int i = 1; i <= N; i++)
             if(num[a[i]] > num[b[i]] - 2)
                num[a[i]] = num[b[i]] - 2,ok = 1;
          for(int i = l; i < r; i++)
             if(num[i + 1] > num[i] + 1)
                num[i + 1] = num[i] + 1,ok = 1;
          for(int i = r - 1; i >= l; i--)
            if(num[i] > num[i + 1])
                num[i] = num[i + 1],ok = 1;
         }
         printf("%d\n",num[r] - num[l]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值