POJ3692——Kindergarten(最大二分匹配)

POJ3692——Kindergarten


description:

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input:

The input consists of multiple test cases. Each test case starts with a line containing three integers G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.
The last test case is followed by a line containing three zeros.

Output:

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input:

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output:

Case 1: 3
Case 2: 4

题意:

  • 就是有一群孩子,男孩子之间互相认识,女孩子之间互相认识,并且有部分男孩子和女孩子认识彼此。

  • 现在老师需要选出一个孩子集合,集合中所有的孩子都互相认识。求集合的最大元素个数。

思路:

  • 首先拿到题,我们想到的是肯定是一个匹配题,那么在匹配题中我们要想办法把各种情况转化为最大匹配来算。

  • 首先我们可以通过题目的输入构建一张图,用邻接矩阵表示,这张图就是关系图,如果两个人认识,就记为1。不认识就记为0。

  • 然后我们可以把图转化为补图,那么补图中有边就表示这两个人其实是不认识的,那么我们要做的就是求最小顶点覆盖(找最少的顶点覆盖所有的边),把这些顶点去除补图中就没有边那么就表示在原图中这些人是互相认识的。即可求出答案。


AC代码

//在构图中,我把男孩当做从1到B,女孩当做从B+1到B+1+G。   

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;

    const int maxn = 410; 
    int G,B,M; 
    int map[maxn][maxn];    //邻接矩阵

    int linker[maxn]; 
    bool used[maxn];
    int uN,vN;              

    bool dfs(int u)
    {
        for(int v = 1;v <= vN ;v++)
        {
            if(map[u][v] && !used[v])
            {
                used[v] = true;
                if(linker[v] == -1 || dfs(linker[v]))
                {
                    linker[v] = u;
                    return true; 
                }
            }
        }
        return false;
    }

    int hungary()
    {
        int res = 0;
        memset(linker,-1,sizeof(linker));
        for(int u = 1;u <= uN ;u ++)
        {
            memset(used,false,sizeof(used));
            if(dfs(u)) res ++;
        }
        return res;
    }

    int main()
    {
        int Case = 1;
        while(scanf("%d %d %d",&G,&B,&M) != EOF && !(G == 0 && B == 0 && M == 0))
        {
            memset(map,0,sizeof(map));
            int n = G + B;                //总共G + B 个人 

            //男生之间的联系 
            for(int i = 1; i <= B ;i ++)
            {
                for(int j = 1; j <= B ;j ++)
                {
                    map[i][j] = 1;
                }
            }

            //女孩之间的联系 
            for(int i = B + 1; i <= n ;i ++)
            {
                for(int j = B + 1; j <= n ;j ++)
                {
                    map[i][j] = 1;  
                } 
            }

            //男女之间的联系 
            for(int i = 0; i < M ;i ++)
            {
                int x, y;
                scanf("%d %d",&x,&y);
                map[x + B][y] = 1;
                map[y][x + B] = 1;
            }

            //求补图
            for(int i = 1 ; i <= n ;i ++)
            {
                for(int j = 1;j <= n;j++)
                {
                    if(map[i][j] == 1)
                        map[i][j] = 0;
                    else map[i][j] = 1;     
                }

            } 

            //这个时候有边就表示两个人之间不认识,那么求最小顶点覆盖,除去这些边,那么剩下的人就全部认识了。
            //求最大匹配
            uN = n; vN = n;
            int x = hungary() / 2;
            int ans = n - x;         //最小顶点覆盖求出,用顶点数减去就时答案
            printf("Case %d: %d\n", Case ++, ans);
        }
        return 0;
    }

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值