1340:【例3-5】扩展二叉树

【题目描述】

由于先序、中序和后序序列中的任一个都不能唯一确定一棵二叉树,所以对二叉树做如下处理,将二叉树的空结点用·补齐,如图所示。我们把这样处理后的二叉树称为原二叉树的扩展二叉树,扩展二叉树的先序和后序序列能唯一确定其二叉树。

现给出扩展二叉树的先序序列,要求输出其中序和后序序列。

【输入】

扩展二叉树的先序序列。

【输出】

输出其中序和后序序列。

【输入样例】

ABD..EF..G..C..

【输出样例】

DBFEGAC
DFGEBC
#include<bits/stdc++.h>
#include<stdlib.h>
#include<cstdio>
using namespace std;
typedef struct node;//struct node 是一个自定义类型,这里可以理解成int  typedef是用来声明一种新的类型
typedef node *tree;//就是声明了一种类型tree ,而tree 实际上就是node*
struct node
{
    char data;
    tree L,R;
};
tree bt;
string s;
int i;
void build(tree &bt)//注意这里的引用
{
    if(s[++i]!='.'){
        bt=new node;
        bt->data=s[i];
        build(bt->L);
        build(bt->R);
    }
    else bt=NULL;
}
void prints(tree bt)
{
    if(bt){
        prints(bt->L);
        cout<<bt->data;
        prints(bt->R);
    }
}
void printx(tree bt)
{
    if(bt){
        printx(bt->L);
        printx(bt->R);
       cout<<bt->data;
    }

}
int main()
{
    cin>>s;
    i=-1;
    build(bt);
    prints(bt);
    cout<<endl;
    printx(bt);
    cout<<endl;
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值