1144 The Missing Number(20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

 

 

 

注意在判断大于0的数的时候如果第一个大于0的不是1,那么应该输出一

要不然18分

#include<cstdio>
#include<string>
#include<algorithm>
#include<iostream>
#include<map>
#include<cmath>
#include<vector>
using namespace std;
const int N = 1e5 + 10;
int s[N];
int p[N];
int main()
{
	int n;
	scanf("%d", &n);
	for (int i = 0;i < n;i++)  scanf("%d", &s[i]);
	sort(s, s + n);
	int flag = 0;
	for (int i = 0;i < n;i++) {
		if (s[i] >0) {
			p[flag++] = s[i];
		}
	}
	if (p[0] != 1) cout << 1 << endl;
	else
	for (int i = 0;i < flag;i++) {
		if (p[i] != p[i + 1] && p[i] != p[i + 1]-1) {
			printf("%d\n",p[i]+1);
			return 0;
		}
	}
	return 0;
}

 

 

用map做更简单点

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin>>n;
    map<int,int>mp;
    for(int i=0;i<n;i++){
        int x;
        cin>>x;
        mp[x]++;
    }
    int num=1;
    while(mp[num]>0) num++;
    cout<<num<<endl;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值