HDU 1060 【取对数+科学记数法】

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

 

Output

For each test case, you should output the leftmost digit of N^N.

 

 

Sample Input

 

2 3 4

 

 

Sample Output

 

2 2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

 

 

Author

Ignatius.L

 

 

Recommend

We have carefully selected several similar problems for you:  1018 1061 1071 1573 1066 


m = n^n,取对数,lg(m) = n*lg(n),所以 m = 10^( n*lg(n)  ),因为10的整数次方都是以1为开头的数,所以第一位之和n*lg(n)的小数部分有关,所以 用自身减去自身的整数部分,留下小数部分,用pow就OK了


#include<bits/stdc++.h>
//#include <iostream>
//#include <cstring>
//#pragma GCC optimize(2)
#include<time.h>
using namespace std;
#define maxn 1255
#define inf 1e18
#define eps 0.00001
typedef long long ll;
const ll mod = 1e9+7;
const double pi = acos(-1);

ll n,t;

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);cout.tie(0);

    //freopen("D:\\test1.in","w",stdout);
    //srand((int)time(0));

    cin >> t;
    double temp;

    while(t--)
    {
        cin >> n;

        temp = n*log10(n); 

        temp -= (ll)temp;  //减去整数部分

        ll ans = pow(10,temp);

        cout << ans << endl;

    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值