PAT 1008 数组元素循环右移问题

1008 数组元素循环右移问题

一个数组A中存有N(>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(≥0)个位置,即将A中的数据由(A​0​​A​1​​⋯A​N−1​​)变换为(A​N−M​​⋯A​N−1​​A​0​​A​1​​⋯A​N−M−1​​)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?
输入格式:

每个输入包含一个测试用例,第1行输入N(1≤N≤100)和M(≥0);第2行输入N个整数,之间用空格分隔。
输出格式:

在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。
输入样例:

6 2
1 2 3 4 5 6

输出样例:

5 6 1 2 3 4

代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include<string>
#include<cstring>
#include<cmath>
#include<set>
#include<queue>
#include<cmath>
#include<map>
#include<list>
#include<stack>
using namespace std;
const int inf = 0x3f3f3f3f;
typedef long long ll;
const double pi = 3.1415926535;
int vis[1000];
vector<int>v;
int arr[105];
int main() {
    int n, m;
    cin >> n >> m;
    for (int i = 0; i < n; i++)
        cin >> arr[i];
    if (m > n)m %= n;  //若m大于n,则右移n个位置不变,对m取余去除这种循环
    int f = 0;
    for (int i = n-m; i < n; i++)
    {
        if (f)cout << " ";
        cout << arr[i];
        f++;
    }
    for (int i = 0; i < n-m; i++)
    {
        if (f)cout << " ";
        cout << arr[i];
        f++;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值