HDU 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12130    Accepted Submission(s): 7550


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1241  1016  1010  1372  1242

这是我真正接触ACM的第一题,也是大一暑假的第一题,但是快一年了,我的水平几乎没有什么本质的提升,我真的浪费了一年,起码在ACM方面,我很后悔!

今天算是复习,把DFS和BFS两种代码都贴一下
首先是DFS
#include<stdio.h>
#include<queue>
#include<iostream>
using namespace std;


char mat[111][111];
int m,n,cnt;
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};

void dfs(int x,int y)
{
    if(mat[x][y]=='#'||x<1||y<1||x>n||y>m)return;
    mat[x][y]='#';
    cnt++;
    for(int i=0;i<4;i++)
    {
        dfs(x+dx[i],y+dy[i]);
    }

}

int main()
{
    int sx,sy;
    while(~scanf("%d%d",&m,&n),(m+n))
    {
        cnt=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            scanf(" %c",&mat[i][j]);
            if(mat[i][j]=='@')sx=i,sy=j;
        }
        dfs(sx,sy);
        cout<<cnt<<endl;
    }




}



然后是BFS
#include<stdio.h>
#include<queue>
#include<iostream>
using namespace std;
struct point
{
    int x,y;
}st;
queue<point>q;
char mat[111][111];
int m,n,cnt;
int dx[]={1,-1,0,0};
int dy[]={0,0,1,-1};

void bfs(int x,int y)
{

    while(!q.empty())q.pop();
    q.push(st);
    mat[st.x][st.y]='#';
    while(!q.empty())
    {
        st=q.front();
        q.pop();
        cnt++;
        for(int i=0;i<4;i++)
        {
            point next=st;
            next.x+=dx[i],next.y+=dy[i];
            if(mat[next.x][next.y]=='#'||next.x<1||next.y<1||next.x>n||next.y>m)continue;
            q.push(next);
            mat[next.x][next.y]='#';
        }
    }
}

int main()
{
    int sx,sy;
    while(~scanf("%d%d",&m,&n),(m+n))
    {
        cnt=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            scanf(" %c",&mat[i][j]);
            if(mat[i][j]=='@')st.x=i,st.y=j;
        }
        bfs(sx,sy);
        cout<<cnt<<endl;
    }
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值