ZOJ Monthly, June 2018.A.Peer Review

There are  students involved in a peer review about their course projects. Each student has to score the other  students' projects separately. The score given must be an integer ranging from 0 to 100 (both inclusive), and the final score of a student is the sum of the scores his project receives.

But these students are on bad terms with each other, so they all want to minimize the sum of the final scores of the other students, and maximize his/her own final score when the first condition is satisfied.

If every student uses the best strategy, can you predict their final scores?

Input

There are multiple test cases. The first line of the input contains an integer  (about 100), indicating the number of test cases. For each test case:

The first and only line contains one integer  (), indicating the number of students involved in the peer review.

Output

For each test case output one line containing  integers separated by one space, indicating the final scores of each student. You should print the answer in non-descending order.

Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

Sample Input
1
2
Sample Output
0 0

#include<iostream>
using namespace std;
int main()
{
    int T,n;
    cin>>T;
    while(T--&&cin>>n){
        for(int i=0;i<n-1;i++)
            cout<<0<<' ';
        cout<<0<<endl;
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值