2018 Multi-University Training Contest 1--Balanced Sequence--hdu--6299

Balanced Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4611    Accepted Submission(s): 1199

Problem Description

Chiaki has n strings s1,s2,…,sn consisting of '(' and ')'. A string of this type is said to be balanced:

+ if it is the empty string
+ if A and B are balanced, AB is balanced,
+ if A is balanced, (A) is balanced.
Chiaki can reorder the strings and then concatenate them get a new string t. Let f(t) be the length of the longest balanced subsequence (not necessary continuous) of t. Chiaki would like to know the maximum value of f(t) for all possible t.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤105) -- the number of strings.
Each of the next n lines contains a string si (1≤|si|≤105) consisting of `(' and `)'.
It is guaranteed that the sum of all |si| does not exceeds 5×106.

Output

For each test case, output an integer denoting the answer.

Sample Input

2

1

)()(()(

2

)

)(

Sample Output

4

2

Source

2018 Multi-University Training Contest 1

题意:

就是给你几个括号序列,让你重新排列这些括号序列,在它们的子序列中组成尽可能多的一对括号,就比如样例2

给你两个序列,分别是")"、")(",可以组成一个"()",所以答案为2.

题解:

也很简单,根据同学讲解,这个使用贪心法,

对字符串进行排序,排序规则如下:

)))))((--左少右多--a 类型

))(((((--左多右少--b 类型

如果 a 与 a 比较:

       按照右括号从多到少排序;

如果 b 与 b 比较:

       按照左括号从少到多排序;

如果 a 与 b 比较:

       按照先 b 后 a 的顺序排序。

最后进行匹配括号计算,结果要乘2。

贴上同学代码

#include <bits/stdc++.h>

using namespace std;

struct node {
	int l, r, much;
} example[100005];

char edge[100005];

bool cmp(node a, node b) {
	if(a.l <= a.r && b.l > b.r) {
		return false;
	} else if(a.l > a.r && b.l <= b.r) {
		return true;
	} else if(a.l <= a.r && b.l <= b.r) {
		return a.l > b.l;
	} else {
		return a.r < b.r;
	}
}

int main() {
	int t;
	scanf("%d", &t);
	while(t--) {
		int n;
		scanf("%d", &n);
		for(int i = 0; i < n; i++) {
			scanf("%s", edge);
			int a = 0, b = 0, c = 0;
			for(int j = 0; edge[j] != '\0'; j++) {
				if(edge[j] == '(') {
					a++;
				} else {
					if(a) {
						a--;
						c++;
					} else {
						b++;
					}
				}
			}
			example[i].l = a;
			example[i].r = b;
			example[i].much = c;
		}
		sort(example, example+n, cmp);
		long long ans = 0, num_l = 0;
		for(int i = 0; i < n; i++) {
			ans += example[i].much;
			if(num_l > example[i].r) {
				ans += example[i].r;
				num_l -= example[i].r;
				num_l += example[i].l;
			} else {
				ans += num_l;
				num_l = example[i].l;
			}
		}
		printf("%lld\n", ans*2);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值