hdu 2717 bfs

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
5 17
 

Sample Output
4

题意:
有个不动的奶牛,农夫要走到奶牛的位置,已知农夫和奶牛的坐标,农夫可以前进一步或者后退一步或者传送到他坐标的两倍处。


思路:BFS,如果超过了2*m,再选择翻倍或+1显然没收益,如果n==m显然只要0步,其他情况都搜索一遍,就能得到结果。

 

#include<stdio.h>
#include<iostream>
#include<queue>
#define MAXN 100050
using namespace std;
int n,m;
int vis[MAXN*2];
int path[MAXN*2];

void bfs(int x)
{
    int i;
    queue<int>q;
    q.push(x);
    int k;
    int now;
    while(!q.empty())
    {
        k=q.front();
        q.pop();
        for(i=0;i<3;i++)
        {
            if(i==0)
                now=k+1;
            else if(i==1)
                now=k-1;
            else
                now=k*2;

            if(now>=0&&now<=MAXN&&!vis[now])
            {
                vis[now]=1;
                q.push(now);
                path[now]=path[k]+1;
            }
            if(now==m)
            {
                printf("%d\n",path[now]);
                return ;
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(vis,0,sizeof(vis));
        memset(path,0,sizeof(path));
        if(n==m)
            printf("0\n");
        else
        bfs(n);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值