Multiplication Puzzle (poj 1651)

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7947 Accepted: 4912

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650



题意:

给出一个数组a,可以将其中除了头尾两个数之外的任何一个数字a[i]取出数列,需要的花费为   a[i-1] * a[i] * a[i+1],问如果需要把这个数列除了头尾之外的数字都取完,怎样的取出顺序是花费最小的,输出这个最小花费


思路:

首先我们可以考虑最小的一个可以操作的区间为3个数字,是可以直接算出答案的。

对于长度小于3的区间,我们可以直接得到 dp[i][i+1] = 0;

对于长度大于3的区间,我们可以在其中找到一个中点,例如区间 i ~ j  取中点k 即分为区间  i~k 和 k~j, 对于区间 i~k 我们有答案 dp[i][k]  对于区间 k~j 我们有答案  dp[k][j] ,而在这两个区间运算完之后 会剩下的是 a[i],a[k],a[j],所以为了消除k我们会有花费 a[i] * a[k] * a[j],即转移方程 :

 dp[i][j] = min(dp[i][j],dp[i][k] + dp[k][j] + a[i]*a[k]*a[j]);


#include"iostream"
#include"cstring"
#include"cstdio"
#include"algorithm"

#define INF 0x7f7f7f7f

using namespace std;

int m;
int a[105];
int dp[105][105];

int main(void)
{
    while(~scanf("%d",&m))
    {
        for(int i = 0;i < m;i++) scanf("%d",&a[i]);

        memset(dp,INF,sizeof(dp));

        for(int i = 0;i < m-1;i++)
        {
            dp[i][i+1] = 0;
        }

        for(int l = 3;l <= m;l++)
        {
            for(int i = 0;i + l - 1 < m;i++)
            {
                for(int k = i+1;k < i + l - 1;k++)
                {
                    dp[i][i+l-1] = min(dp[i][i+l-1],dp[i][k] + dp[k][i+l-1] + a[i]*a[k]*a[i+l-1]);
                }
            }
        }
        printf("%d\n",dp[0][m-1]);
    }
    return 0;
}


数据治理是确保数据准确性、可靠性、安全性、可用性和完整性的体系和框架。它定义了组织内部如何使用、存储、保护和共享数据的规则和流程。数据治理的重要性随着数字化转型的加速而日益凸显,它能够提高决策效率、增强业务竞争力、降低风险,并促进业务创新。有效的数据治理体系可以确保数据在采集、存储、处理、共享和保护等环节的合规性和有效性。 数据质量管理是数据治理中的关键环节,它涉及数据质量评估、数据清洗、标准化和监控。高质量的数据能够提升业务决策的准确性,优化业务流程,并挖掘潜在的商业价值。随着大数据和人工智能技术的发展,数据质量管理在确保数据准确性和可靠性方面的作用愈发重要。企业需要建立完善的数据质量管理和校验机制,并通过数据清洗和标准化提高数据质量。 数据安全与隐私保护是数据治理中的另一个重要领域。随着数据量的快速增长和互联网技术的迅速发展,数据安全与隐私保护面临前所未有的挑战。企业需要加强数据安全与隐私保护的法律法规和技术手段,采用数据加密、脱敏和备份恢复等技术手段,以及加强培训和教育,提高安全意识和技能水平。 数据流程管理与监控是确保数据质量、提高数据利用率、保护数据安全的重要环节。有效的数据流程管理可以确保数据流程的合规性和高效性,而实时监控则有助于及时发现并解决潜在问题。企业需要设计合理的数据流程架构,制定详细的数据管理流程规范,并运用数据审计和可视化技术手段进行监控。 数据资产管理是将数据视为组织的重要资产,通过有效的管理和利用,为组织带来经济价值。数据资产管理涵盖数据的整个生命周期,包括数据的创建、存储、处理、共享、使用和保护。它面临的挑战包括数据量的快速增长、数据类型的多样化和数据更新的迅速性。组织需要建立完善的数据管理体系,提高数据处理和分析能力,以应对这些挑战。同时,数据资产的分类与评估、共享与使用规范也是数据资产管理的重要组成部分,需要制定合理的标准和规范,确保数据共享的安全性和隐私保护,以及建立合理的利益分配和权益保障机制。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值