PAT-甲级-1003

1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 
4
【解析】
题目会给你n个城市m条路,起点城市和终点城市,叫你求最短路径有几条路,以及最多的搜救队数量,其实就是用Dijksrra算法。我个人感觉这个代码要背和理解熟,最好能做到背出来的效果因为你理解了,背的话也应该差不多了,附上他人代码解析,包括自己的一些解析代码。
#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;
const int CITYNUM = 500;
const int INF = 0x7fffffff;
int city[CITYNUM];			//记录各个城市的团队数
int road[CITYNUM][CITYNUM]={0};
bool visited[CITYNUM]={false};
int minLen[CITYNUM]={0};	//从源城市到达index城市的最短路径值
int sum[CITYNUM]={0};		//从源城市到达index城市,所能召集的最大团队数
int same[CITYNUM]={0};		//从源城市到达index城市,具有相同最短的路径个数
void Dij(int source,int dest,int n){		//dijkstra算法
	int i,t,mm,next;
	int count = 0;
	int cur = source;
	sum[cur]=city[cur];//目标城市的团队数
	same[cur]=1;//从起点到终点的路径数
	while(count< n-1){
		visited[cur]=true;
		mm=INF;
		for(i=0;i<n;i++){
			if(visited[i])//遇到源起点跳过
                continue;
			if(road[cur][i]){//此处表示目标点到第i个城市是有路的
				t = minLen[cur]+road[cur][i];
				if(t<minLen[i]||minLen[i]==0){		//到达城市i,出现新的最短路径
					minLen[i]=t;
					same[i]=same[cur];			//重新计数,可能到达本节点cur的最短路径有多条
					sum[i]=sum[cur]+city[i];//之前的团队数加上现在的团队数
				}else if(t == minLen[i]){			//到达城市i,出现相同的最短路径
					same[i]+=same[cur];
					if(sum[cur]+city[i]> sum[i])	//记下团队数较大的值
						sum[i]=sum[cur]+city[i];
				}
			}
			if(minLen[i] < mm && minLen[i]!=0){
				mm = minLen[i];
				next = i;
			}
		}
		minLen[cur] = mm;
		if(next == dest)break;
		cur = next;
		count++;
	}
	return;
}
int main()
{
	int n,m,sc,dc;
	cin>>n>>m>>sc>>dc;
	int i;
	for(i=0;i<n;i++)cin>>city[i];
	int c1,c2;
	for(i=0;i<m;i++){
		cin>>c1>>c2;
		cin>>road[c1][c2];
		road[c2][c1]=road[c1][c2];
	}
	if(sc==dc){							
		cout<<1<<' '<<city[sc]<<endl;
		return 0;
	}
	Dij(sc,dc,n);
	cout<<same[dc]<<' '<<sum[dc]<<endl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值