ZCMU-1053-Master-Mind Hints

1053: Master-Mind Hints

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 51   Solved: 31
[ Submit][ Status][ Web Board]

Description

MasterMind is a game for two players. One of them,  Designer, selects a secret code. The other,  Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length  N that a code must have and upon the colors that may occur in a code.
In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.
In this problem you will be given a secret code s1…sn and a guess g1…gn, and are to determine the hint. A hint consists of a pair of numbers determined as follows.
match is a pair ( i, j),1<=i<=n and 1<=j<=n, such that si=gi. Match ( i, j) is called  strong when  i =  j, and is called  weakotherwise. Two matches ( i, j) and ( p, q) are called  independentwhen  i =  p if and only if  j =  q. A set of matches is called  independent when all of its members are pairwise independent.
Designer chooses an independent set  M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in  M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be ( n,0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying  N (the length of the code). Following these will be the secret code, represented as  N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as  Nintegers, each in the range 1 to 9. Following the last guess in each game will be  N zeroes; these zeroes are not to be considered as a guess.
Following the data for the first game will appear data for the second game (if any) beginning with a new value for  N. The last game in the input will be followed by a single zero (when a value for  Nwould normally be specified). The maximum value for  N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exactformat.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 00

Sample Output

Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)

【解析】
最头痛英语题不为别的,虽然阅读理解稍微好一点..不过这个嘛题目读着完全不是阅读理解嘛。其实题目的意思就是
先给你一个序列,然后再给你一个序列叫你进行匹配比如说样例1,先给你一个1 3 5 5,后面再给你1 1 2 3.叫你统
计a[i]=b[i]的有几个注意这里必须是相同位置,后面叫你统计的是出现在不同的位置相同的数有几个,a[i]=b[j]当
然了前面已 经统计过的相同位置的不算在内的,然后再按照格式输出,样例1当中的其中一个例子就是我上面说的,1
这个位置是 相同的所以x坐标是1,不同位置相同的就只有一个3,所以y也是3,当输入的序列都是0的时候我们就跳出
循环,不然 是一直循环输入b序列的。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int n,i,count1,count2,count3,j;
    int p=1;
    int a[10001];
    int b[10001];
    int c[10001];
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);//输入原序列
        printf("Game %d:\n",p++);
        while(1)
        {

            count1=0;
            count2=0;
            count3=0;
            memset(b,0,sizeof(b));
            for(i=0;i<n;i++)
            {
                scanf("%d",&b[i]);//输入需要查询的序列
                c[i]=a[i];
                if(b[i]==0)
                    count3++;//统计0有多少个
            }
            if(count3==n)
                break;
            for(i=0;i<n;i++)//统计相同位置字符数
            {
                if(c[i]==b[i])
                {
                    c[i]=0;
                    b[i]=0;
                    count1++;
                }

            }
            for(i=0;i<n;i++)
            {
                if(c[i]!=0)
                {
                    for(j=0;j<n;j++)//统计不同位置相同的字符数
                    {
                        if(c[i]==b[j])
                        {
                            count2++;
                            c[i]=0;
                            b[j]=0;
                            break;
                        }
                    }
                }
            }
        printf("    (%d,%d)\n",count1,count2);
    }
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值