ZCMU-甲级-1120

1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
【解析】
这道题的意思是给你中序和后序序列,叫你输出层次遍历,层次遍历的意思就是一层一层的输出。和求前序类似,这里就是加了个下标意思就是在该层的下标,该层下标和下同一左子树的关系就是2*i+1。
#include<iostream>
#include <cstdio>
#include<cstring>
#include<vector>
using namespace std;
vector<int> a,b,level(100010, 0);
void pre(int root, int start, int end, int index) {
    if(start > end) return ;
    int i = start;
    while(i < end && b[i]!=a[root])//寻找根结点
        i++;
    level[index]=a[root];
    pre(root - 1 - end + i, start, i - 1, 2 * index + 1);//下标表示的是层次遍历
    pre(root - 1, i + 1, end, 2 * index + 2);
}
int main()
{
    int n,i;
    int count1=0;
    scanf("%d", &n);
    a.resize(n);
    b.resize(n);
    for(i = 0; i < n; i++)
        scanf("%d", &a[i]);
    for(i = 0; i < n; i++)
        scanf("%d", &b[i]);
    pre(n-1, 0, n-1, 0);
    for(int i = 0; i < level.size(); i++) {
        if(level[i] != 0&& count1!= n - 1)
            {
            printf("%d ", level[i]);
            count1++;
        }
        else if(level[i]!= 0)
            {
            printf("%d",level[i]);
            break;
           }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值