Big Event in HDU(母函数)

                                                    Big Event in HDU

                     Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
        Total Submission(s): 23902    Accepted Submission(s): 8424


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 

Author
lcy

题意: 题目其实理解起来就是一个把一堆数尽量分成相等的两部分,当不能分成相等的两部分时就保证A大于B;

意解: 母函数的转化,题目可以这样解,把一堆数的和累加起来,除以2,然后就像背包一样一直趋近这个数,就可以了;

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int M = 1e6 * 2; //注意范围;
int vis[M];//标记数组,标记一个数是否可以由给出的数组合得到;

struct M
{
    int a,b;
    void read()
    {
        scanf("%d %d",&a,&b);
    }
}m[100];

int main()
{
    int n;
    while(~scanf("%d",&n) && n > 0)
    {
        int sum = 0;
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++)
        {
            m[i].read();
            sum += m[i].a * m[i].b;
        }
        int ans = sum / 2;
        int res = 0;
        vis[0] = 1;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j <= m[i].b * m[i].a; j += m[i].a)
            {
                for(int k = 0; k <= res; k++)
                {
                    if(k > ans) break;
                    if(vis[k])
                    {
                        vis[k + j] = 1; //如果存在这样的数,则标记
                    }
                }
                res += m[i].b * m[i].a; //累加当前可以组成的最大的数
            }
        }
        for(int i = ans; i >= 0; i--)//倒着找,可以找出一组最接近的数
        {
            if(vis[i])
            {
                ans = i;
                break;
            }
        }
        printf("%d %d\n",sum - ans,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值