pycharm 切换 python3.9 出现报错

在pycharm中将python3.7切换为3.9之后,设置项目解释器时一直提示 AttributeError: ‘HTMLParser’ object has no attribute 'unescape’
经过看这位大佬的文章,发现是由于setuptools的版本导致的,原因原博解释的很详细,我采用了创建虚拟环境的方式解决,为了便于之后查看,在此记录一下。
1.安装virtualenv
打开cmd,安装virtualenv

pip install virtualenv

2.创建虚拟环境

virtualenv可用于创建虚拟环境,如果需要删除虚拟环境可直接删除对应文件夹。

virtualenv D:\Programs\python39\lprenv

3.在pycharm中,配置创建的虚拟环境
路径:“File – Settings – Project Interpreter – Add – Existing environment”,选择创建的env文件夹下的Scripts中的python.exe。
在这里插入图片描述
确认之后就搞定了!

  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rena要努力

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值