寒假训练补题-第十二天-H8-最小生成树

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

有N个村庄,编号从1到N,你应该建造一些道路,使每两个村庄可以相互连接。我们说两个村A和B是相连的,当且仅当A和B之间有一条道路,或者存在一个村C以便在A和C之间有一条道路,并且C和B相连。

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

我们知道一些村庄之间已经有一些道路,你的工作就是修建一些道路,使所有村庄都连通起来,所有道路的长度都是最小的。

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village.

输入
第一行是整数N(3 <= N <= 100),这是村庄的数量。然后是N行,其中第i个包含N个整数,这些N个整数中的第j个是村庄i和村庄j之间的距离(距离应该是[1,1000]内的整数)。

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

*然后是整数Q(0 <= Q <= N (N + 1)/ 2)。然后是Q行,每行包含两个整数a和b(1 <= a <b <= N),这意味着村庄a和村庄b之间的道路已经建成。

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

产量
您应该输出一个包含整数的行,该整数是要构建的所有道路的长度,以便连接所有村庄,并且此值最小。

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define Maxn 110
#define inf 0x3f3f3f3f
using namespace std;
 
int lowc[Maxn];
int cost[Maxn][Maxn];
int vis[Maxn];
 
int prim(int n){
    int ans = 0;
    memset(vis, 0, sizeof(vis));
    vis[0] = 1;
    for(int i = 1; i < n; i++)lowc[i] = cost[0][i];
    for(int i = 1; i < n; i++){
        int minc = inf;
        int p = -1;
        for(int j = 0; j < n; j++){
            if(!vis[j] && minc > lowc[j]){
                p = j;
                minc = lowc[j];
            }
        }
        ans += minc;
        vis[p] = 1;
        for(int j = 0; j < n; j++){
            if(!vis[j] && lowc[j] > cost[p][j]){
                lowc[j] = cost[p][j];
            }
        }
    }
    return ans;
}
 
void in(){
    int n;
    while(cin >> n && n){
        for(int i = 0; i <= n - 1; i++){
            for(int j = 0; j <= n - 1; j++){
                cin >> cost[i][j];
            }
        }
        int m;
        cin >> m;
        for(int i = 1; i <= m; i++){
            int u, v;
            cin >> u >> v;
            cost[u - 1][v - 1] = cost[v - 1][u - 1] = 0;
        }
        cout << prim(n) << endl;
    }
}
int main(){
    in();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值