练习四1002

Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.<br>Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?<br>
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. <br><br>Input contains multiple test cases. Process to the end of file.<br>
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. <br>
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41
题意:第一行是坐标系中点的个数,每一行代表一个点的横纵坐标,求最小生成树。
思路:设计两个结构体,一个表达坐标,另一个表示边,其余的部分用Kruskal的套路即可。
#include<iostream>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<stdio.h>
using namespace std;
const int N=100;
int root[N];
struct point
{
    int r;
    double x,y;
}p[N*N];
struct edge
{
    point m,n;
    double w;
}e[N*(N-1)/2];
int find(int x)
{
    if(x!=root[x])
    {
        root[x]=find(root[x]);
    }
    return root[x];
}
int cmp(edge e1,edge e2)
{
    return e1.w<e2.w;
}
int main()
{
    int n,i;
    cin>>n;
    int t=n*(n-1);
    for(i=0;i<n;i++)
    {
        cin>>p[i].x>>p[i].y;
        p[i].r=i;
        root[i]=p[i].r;
    }
    int num=0;
    for(int i=0;i<n;i++)
    {
        for(int j=i+1;j<n;j++)
        {
            e[num].m=p[i];
            e[num].n=p[j];
            e[num].w=sqrt(pow(p[i].x-p[j].x,2)+pow(p[i].y-p[j].y,2));
            num++;
        }
    }
    sort(e,e+t,cmp);
    double distance=0;
    for(i=0;i<t;i++)
    {
        int x=find(e[i].m.r);
        int y=find(e[i].n.r);
        if(x!=y)
        {
            root[x]=y;
            distance+=e[i].w;
        }
    }
    cout<<setprecision(3)<<distance<<endl;
    //printf("%.2lf\n",distance);
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值