POJ1679(次小生成树)

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24201 Accepted: 8596

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.  

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
题意:判断是否存在唯一的最小生成树。
思路:先求出一个最小生成树。在这颗树上先加入(x,y),加入后一定会成环,如果删除(x,y)以外最大的一条边,会得到加入(x,y)时权值最小的一棵树。如果加入的边和删除的边相等,则最小生成不是唯一的。
收获:了解了次小生成树。
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);
#define maxn 500
int n, m;
int a[maxn][maxn];
int used[maxn][maxn];
int mmax[maxn][maxn];
int vis[maxn];
int dis[maxn];
int pre[maxn];
int prim()
{
    int ans = 0;
    memset(vis, 0, sizeof vis);
    memset(used, 0, sizeof used);
    memset(mmax, 0 ,sizeof mmax);
    for(int i = 2; i <= n; i++)
    {
        dis[i] = a[1][i];
        pre[i] = 1;
    }
    vis[1] = 1;
    dis[1] = 0;
    for(int i = 1; i < n; i++)
    {
        int temp = INF;
        int k = -1;
        for(int j = 1; j <= n; j++)
        {
            if(!vis[j] && temp > dis[j])
            {
                temp = dis[j];
                k = j;
            }
        }
        if(k == -1) return ans;
        ans += temp;
        vis[k] = 1;
        used[k][pre[k]] = used[pre[k]][k] = 1;
        mmax[pre[k]][k] = temp;
        for(int j = 1; j <= n; j++)
        mmax[j][k] = max(mmax[j][pre[k]],mmax[pre[k]][k] );//找最大的边权的边。
        for(int j = 1; j <= n; j++)
        {
            if(!vis[j] && dis[j] > a[k][j])
            {
                dis[j] = a[k][j];
                pre[j] = k;
            }
        }
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        int u, v, w;
        memset(a, INF, sizeof a);
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            a[u][v] = a[v][u] = w;
        }
        int mst = prim();
        int flag = 0;
        for(int i = 1; i <= n; i++)
            for(int j = i+1; j <= n; j++)
            {
                if(a[i][j] == INF || used[i][j] == 1)
                    continue;
                if(a[i][j] == mmax[i][j])//判断加入的边和删除的边是否相等。
                {
                    flag = 1;
                    break;
                }
            }
        if(flag)
        printf("Not Unique!\n");
        else
        printf("%d\n",mst);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/ZP-Better/p/4734298.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值