poj 1308 Is It A Tree?

点击打开链接

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18904 Accepted: 6448

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
题目大意不用说了,看题目就知道

输入数据也没什么难的,就是 a b 代表a->b有一条边每组数据以0 0结束

题目有很多办法解决,要么利用搜索,找到入度为0的点开始向下搜索,要么利用树的性质,这题我是用了树的几个特性,写的有点啰嗦了,可能用搜索简单点吧。。

1,直接输入0 0 是一棵树

2,如果入度为0的点超过2个,不是树

3,如果点v和边e的关系不满足e + 1 == v,不是树

4,如果某个点的入度超过2个,不是树

如果满足2、 3、 4的条件,那就是树

#include<stdio.h>

int count[10001];
bool hash[10001];
int number[10001];
int main()
{
	int a, b;
	int i = 1;
	int bian = 0;
	while(scanf("%d %d", &a, &b), a != -1 || b!= -1)
	{
		int j;
		int flag;
		int top = 0;
		bian  = 0;
		for(j = 0; j < 10001; j++)
		{
			hash[j] = count[j] = number[j] = 0;
		}
		if(a == 0 && b ==0 )
		{
			printf("Case %d is a tree.\n", i);
			i++;
			continue;
		}
		if(hash[a] == 0)
		{
			hash[a] = 1;
			number[top ++] = a;
		}
		if(hash[b] == 0)
		{
			hash[b] = 1;
			number[top ++] = b;
		}
		bian ++;
		count[b] ++;
		while(scanf("%d %d", &a, &b), a!= 0 || b != 0)
		{
			count[b] ++;
			bian ++;
			if(hash[a] == 0)
			{
				hash[a] = 1;
				number[top ++] = a;
			}
			if(hash[b] == 0)
			{
				hash[b] = 1;
				number[top ++] = b;
			}
		}
		if( bian + 1 != top)
		{
			printf("Case %d is not a tree.\n", i);
			i++;
			continue;
		}
		flag = 0;
		for(j = 0; j < top; j++)
		{
			if(count[number[j]] > 1)
			{
				printf("Case %d is not a tree.\n", i);
				break;
			}
			else if(count[number[j]] == 0)
			{
				if(flag == 1)
				{
					printf("Case %d is not a tree.\n", i);
					break;
				}
				else
				{
					flag = 1;
				}
			}
		}
		if(j == top)
		{
			printf("Case %d is a tree.\n", i);
		}
		i++;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值