2013年山东省第四届ACM大学生程序设计竞赛-最后一道大水题:Contest Print Server

点击打开链接

2226: Contest Print Server

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 53   Solved: 18
[ Submit][ Status][ Web Board]

Description

In ACM/ICPC on-site contests ,3 students share 1 computer,so you can print your source code any time. Here you need to write a contest print server to handle all the requests.

Input

In the first line there is an integer T(T<=10),which indicates the number of test cases.

In each case,the first line contains 5 integers n,s,x,y,mod (1<=n<=100, 1<=s,x,y,mod<=10007), and n lines of requests follow. The request is like "Team_Name request p pages" (p is integer, 0<p<=10007, the length of "Team_Name" is no longer than 20), means the team "Team_Name" need p pages to print, but for some un-know reason the printer will break down when the printed pages counter reached s(s is generated by the function s=(s*x+y)%mod ) and then the counter will become 0. In the same time the last request will be reprint from the very begin if it isn't complete yet(The data guaranteed that every request will be completed in some time).

You can get more from the sample.

Output

Every time a request is completed or the printer is break down,you should output one line like "p pages for Team_Name",p is the number of pages you give the team "Team_Name".

Please note that you should print an empty line after each case.

Sample Input

23 7 5 6 177Team1 request 1 pagesTeam2 request 5 pagesTeam3 request 1 pages3 4 5 6 177Team1 request 1 pagesTeam2 request 5 pagesTeam3 request 1 pages

Sample Output

1 pages for Team15 pages for Team21 pages for Team31 pages for Team13 pages for Team25 pages for Team21 pages for Team3

HINT

Source


这题没法说了,说了全是泪啊,无脑模拟就可以过的,可是比赛的时候有人嘴贱问了一句会不会输出打印0张的情况,裁判回了一句no,从此全场走上了一条不归路,这题只有在最后恰好打印完才不会输出0张,在打印过程中出现刚好打印完的情况下,下一个队申请打印的时候是一定会输出一句打印0张的,天坑!!!看了AC代码才明白,哎

#include<stdio.h>
int main()
{
//	freopen("in.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while(t--)
	{
		int n, s, x, y, mod;
		scanf("%d%d%d%d%d", &n, &s, &x, &y, &mod);
		int count = s;
		int i;
		for(i = 0; i < n; i++)
		{
			char name[40], request[10], page[10];
			int num;
			scanf("%s %s %d %s", name, request, &num, page);
			while(1)
			{
				if(num > count)
				{
					printf("%d pages for %s\n", count, name);
					s = (s * x + y) % mod;
					if(s == 0)
						s = (s * x + y) % mod;
					count = s;
				}
				else if(num == count)
				{
					printf("%d pages for %s\n", count, name);
					count -= num;
					break;
				}
				else
				{
					printf("%d pages for %s\n", num, name);
					count -= num;
					break;
				}
			}
			
		}
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值